Ask Your Question
0

Launching youBot driver and simulating the robot

asked 2011-04-06 18:31:10 -0500

ASMIK2011ROS gravatar image

Dear ROS users,

my intention is to run the simulation of a robot (KUKA youbot), so that I could be able to control the virtual model in rviz. As far as I understood from the Guide, to solve this task one has to launch RVIZ, launch the OODL driver for the robot in parallel and launch the state publisher (youbot_joint_state_publisher). RVIZ can be launched and the state publisher seems to launch properly (though I don't understand what use is made of it; shouldn't it have some GUI??). PROBLEM: can't launch the driver:

youbot@oleksandr-laptop:~$ roscd youbot_oodl/launch

youbot@oleksandr-laptop:~/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl/launch$ ./start_youbot_oodl_driver

[sudo] password for youbot:

[rosrun] Couldn't find executable named youbot_oodl below /home/youbot/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl

[rosrun] Found the following, but they're either not files,

[rosrun] or not executable:

[rosrun] /home/youbot/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl

In /home/youbot/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl/launch THERE IS A FILE NAMED start_youbot_oodl_driver..

I will be grateful for any help!!! Hope to get it very much.

edit retag flag offensive close merge delete

Comments

which repo are you using?
KoenBuys gravatar image KoenBuys  ( 2011-04-06 21:38:14 -0500 )edit
...What I actually did, I followed the steps described here: http://youbot-store.com/frameworks/8/software.aspx.. And so, when I come to ./start_youbot_oodl_driver, it says that there is no executable file named youbot_oodl.. But in slightly different folder (/home/youbot/ros_stacks/youbot_drivers/youbot_oodl/src) there is a file youbot_oodl.cpp.. I try to compile it to get an executable, but gcc returns a bunch of errors...gcc youbot_oodl.cpp In file included from youbot_oodl.cpp:40: YouBotOODLWrapper.h:44:33: error: geometry_msgs/Twist.h: No such file or directory YouBotOODLWrapper.h:45:38: error: tf/transform_broadcaster.h: No such file or directory YouBotOODLWrapper.h:46:31: error: nav_msgs/Odometry.h: No such file or directory YouBotOODLWrapper.h:48:45: error: trajectory_msgs/JointTrajectory.h: No such file or directory .... u.s.w.
ASMIK2011ROS gravatar image ASMIK2011ROS  ( 2011-04-07 06:39:02 -0500 )edit
Did you try to compile ir with rosmake?
jsogorb gravatar image jsogorb  ( 2011-04-07 21:01:04 -0500 )edit
As far as I understand, rosmake is used to compile packages, not c++ files... But I tried and got: youbot@oleksandr-laptop:~/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl/src$ ls youbot_oodl.cpp YouBotOODLWrapper.cpp YouBotOODLWrapper.h youbot@oleksandr-laptop:~/ros_stacks/youbot-ros-pkg/youbot_drivers/youbot_oodl/src$ rosmake youbot_oodl.cpp [ rosmake ] Packages requested are: ['youbot_oodl.cpp'] [ rosmake ] Logging to directory/home/youbot/.ros/rosmake/rosmake_output-20110408-164436 [ rosmake ] Expanded args ['youbot_oodl.cpp'] to: [] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['youbot_oodl.cpp'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.
ASMIK2011ROS gravatar image ASMIK2011ROS  ( 2011-04-08 02:48:01 -0500 )edit
Could you make sure that your "youbot" package directory is in the $ROS_PACKAGE_PATH environment variable?
jsogorb gravatar image jsogorb  ( 2011-04-10 20:23:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-04-06 19:55:17 -0500

updated 2011-04-07 21:00:22 -0500

First of all I have no experience with youbot package but i think you should try to run the nodes you need like this:

$roscore
$roslaunch package_name executable_name

for example: (I'm not sure about the package or executable names as I don't have installed youbot stack)

$roslaunch youbot_oodl start_youbot_oodl_driver 
$roslaunch rviz rviz
$roslaunch youbot_oodl youbot_joint_state_publisher
edit flag offensive delete link more

Comments

1
Thank you for the answer. But this didn't help. But I found the way to launch the driver: after "compiling the folder" youbot_oodl with rosmake, everything compiled (as it did always before), but this time I noticed the following lines in the end of rosmake logs: [ rosmake ] Summary output to directory; rosmake ] /home/youbot/.ros/rosmake/rosmake_output-20110407-205612 SO I CHANGED THE DIRECTORY TO THIS rosmake output directory and managed to perform rosrun youbot_oodl youbot_oodl !!! However this returned A NEW ) bunch of exciting errors!! : Info: Initializing Joints [FATAL] [1302274632.192262876]: Cannot open youBot driver: No socket connection on eth0 Excecute as root [ERROR] [1302274632.192681854]: Base could not be initialized! Info: Initializing Joints [FATAL] [1302274632.193422032]: Cannot open youBot driver: Not enough ethercat slaves were found to create a YouBotManipulator! [ERROR] [1302274632.193492921]: Arm could not be initialized!
ASMIK2011ROS gravatar image ASMIK2011ROS  ( 2011-04-08 02:52:10 -0500 )edit
So, how could I try to perform the simulation of the robot and control the rviz robot model? Maybe someone has suggestions? I try to follow the instructions given here http://youbot-store.com/simulation/12/software.aspx. But when I type roslaunch youbot_description youbot_arm_publisher_no_x.launch, I get an ERROR: process[arm_trajectory_republisher-1]: started with pid [3615] ERROR: cannot launch node of type [gazebo/gazebo]: Cannot locate node of type [gazebo] in package [gazebo] AND from gazebo import gazebo_interface ImportError: No module named gazebo [youbot_gazebo_model-3] process has died [pid 3616, exit code 1]. log files: /home/youbot/.ros/log/6bd68d42-61f0-11e0-bde2-0013773a743d/youbot_gazebo_model-3*.log
ASMIK2011ROS gravatar image ASMIK2011ROS  ( 2011-04-08 03:07:08 -0500 )edit
The problem with gazobe may be because you don't have it installed in your system. Try to install it form "sudo apt-get install ros-diamontback-gazebo".
jsogorb gravatar image jsogorb  ( 2011-04-10 20:21:11 -0500 )edit
The problem with gazobe may be because you don't have it installed in your system. Try to install it form "sudo apt-get install ros-diamontback-gazebo".
jsogorb gravatar image jsogorb  ( 2011-04-10 20:21:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-06 18:31:10 -0500

Seen: 2,737 times

Last updated: Apr 07 '11