Ask Your Question
0

a global and local map question

asked 2013-10-24 08:02:07 -0600

rnunziata gravatar image

updated 2013-10-25 04:45:39 -0600

In the image below there are two blue crest. If I toggle off the global map panel then the right one disappears. If I toggle off the local map panel then the left one disappears. My global static map in the map server is blank so the image is real-time! Why are these not aligned?

rosmap.yaml  for map server

image: rosmap.pgm
resolution: 0.005000
origin: [-10.000000, -10.000000, 0.000000]
negate: 0
occupied_thresh: 0.65
free_thresh: 0.196


costmap_common_params.yaml for common costmap parameters

obstacle_range:         2.5
raytrace_range:         3.0
footprint:              [[0.25, 0.1], [0.25, -0.1], [-0.25,-0.1], [-0.25, 0.1]] 
max_scaling_factor:     0.02  # The scalling factor for footprint defined in local costmap
inflation_radius:       0.02 # Propagating cost values out from occupied cells that decrease with distance.
map_type:               costmap
track_unknown_space:    true
observation_sources:    laser_scan_sensor 
laser_scan_sensor:      {sensor_frame: hokuyo_frame, data_type: LaserScan, topic: /scan, marking: true, clearing: true}
resolution:             0.005

local_costmap:
  global_frame:      /odom
  robot_base_frame:  /base_link
  update_frequency:  10.0
  publish_frequency: 10.0
  static_map:        true
  rolling_window:    false
  width:             16.0
  height:            16.0
  origin_x:          -8.0
  origin_y:          -8.0


global_costmap:
  global_frame:        /map
  robot_base_frame:    /base_link
  update_frequency:    30.0
  publish_frequency:   30.0
  static_map:          true
  width:               20.0
  height:              20.0
  origin_x:            -10.0
  origin_y:            -10.0

Static map:

image description

image description

edit retag flag offensive close merge delete

Comments

You should add how you configured your costmaps, especially their origins and staticness.

felix k gravatar image felix k  ( 2013-10-25 03:34:27 -0600 )edit

I updated question with this information,

rnunziata gravatar image rnunziata  ( 2013-10-25 04:39:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-25 05:43:46 -0600

David Lu gravatar image

The local map should not be configured to use the static map.

edit flag offensive delete link more

Comments

please see http://answers.ros.org/question/93686/preplexing-local-cost-map-problem/ i will close this but it right now it is the only way I have of running. OK.just tested if I just keep DWA off the static map can be off also and it will move forward.

rnunziata gravatar image rnunziata  ( 2013-10-25 05:52:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-24 08:02:07 -0600

Seen: 1,330 times

Last updated: Oct 25 '13