Ask Your Question
0

/base_scan observation buffer has not been updated [closed]

asked 2014-05-29 22:45:06 -0500

m.hoev gravatar image

updated 2014-06-11 02:59:38 -0500

Hi,

i am trying to get the navigation stack running. Hokuyo is the laser scanner i am using. When i am launching move_base_local.launch i receive the warning

"The /base_scan observation buffer has not been updated for XX.XX seconds, and it should be updated every 0.20 seconds."

My launch file is: <launch>

<param name="T" type="double" value="0.2"/>
<param name="dt" type="double" value="0.1"/>

<node pkg="youbot_navigation_common" type="lowpass_filter" respawn="false" name="lowpass_filter" output="screen">

</node>

<!-- for moving -->
<node pkg="move_base" type="move_base" respawn="false" name="move_base_node" output="screen">
    <!-- Load common configuration files -->
<remap from="cmd_vel" to="move_base/cmd_vel"/> 
    <rosparam file="$(find youbot_navigation_common)/config/move_base_params.yaml" command="load" />
    <rosparam file="$(find youbot_navigation_common)/config/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find youbot_navigation_common)/config/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <!--<rosparam file="$(find youbot_navigation)/navigation_common/base_local_planner_params.yaml" command="load" ns="TrajectoryPlannerROS" />-->

    <!-- Load global navigation specific parameters -->
    <!--<rosparam file="$(find youbot_navigation)/navigation_local/config/move_base_params.yaml" command="load" />-->
    <rosparam file="$(find youbot_navigation_local)/config/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find youbot_navigation_local)/config/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find youbot_navigation_common)/config/base_local_planner_params.yaml" command="load" />
</node>

</launch>

My local_costmap_params.yaml is:

local_costmap:
publish_voxel_map: true
global_frame: odom
robot_base_frame: base_footprint
update_frequency: 5.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 10.0
height: 10.0
resolution: 0.05
origin_x: 0.0
origin_y: 0.0

My global_costmap is:

global_costmap:
publish_voxel_map: true
global_frame: odom
robot_base_frame: base_footprint
update_frequency: 5.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 20.0
height: 20.0
resolution: 0.05
origin_x: 0.0
origin_y: 0.0

My costmap_common_params.yaml is this:

map_type: costmap
transform_tolerance: 0.2
obstacle_range: 2.5
raytrace_range: 3.0
inflation_radius: 0.25

observation_sources: base_scan

#base_scan_marking: {sensor_frame: base_scan_link,
#                    data_type: PointCloud2,
#                    topic: /base_scan/marking,
#                    expected_update_rate: 0.2,
#                    observation_persistence: 0.0,
#                    marking: true,
#                    clearing: false,
#                    min_obstacle_height: 0.06,
#                    max_obstacle_height: 2.0}

base_scan: {sensor_frame: base_laser_front_link,
        data_type: LaserScan,
        topic: /base_scan,
        expected_update_rate: 0.2,
        observation_persistence: 0.0,
        marking: true,
        clearing: true,
        min_obstacle_height: -0.10,
        max_obstacle_height: 2.0}

What am i missing or doing wrong? Cannot figure it out myself and couldn't find any proper answers online.

Thanks a lot.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by m.hoev
close date 2014-08-05 05:07:34.052718

Comments

Does the message appear once or many times? Can you confirm that the topic is properly connected while running?

David Lu gravatar imageDavid Lu ( 2014-05-30 06:41:32 -0500 )edit

Sorry for answering that late. The message appears again and again. What do you mean with "the topic is properly connected?" I am using ros hydro on ubuntu 12.04 by the way. Just in case this is important. Note that i added my costmap_common_params.yaml.

m.hoev gravatar imagem.hoev ( 2014-06-11 02:40:04 -0500 )edit

check if Hokuyo publishes under /base_scan, according to http://wiki.ros.org/hokuyo_node#Published_Topics it publishes under /scan by default

pkohout gravatar imagepkohout ( 2014-06-11 04:45:03 -0500 )edit

No, it is publishing under /scan.

m.hoev gravatar imagem.hoev ( 2014-06-11 05:54:14 -0500 )edit

then you have to change the topic in your costmap_common_params.yaml to /scan, you currently have set it to /base_scan. Does it works then ?

pkohout gravatar imagepkohout ( 2014-06-11 06:17:26 -0500 )edit

No. It still doesn't work. I changed sensor frame to laser aswell, because i need to chose laser in rviz to see laser scans but this did not solve the problem either. Thougt the issue could be with my tf tree, but it is odom -> base_footprint -> laser...this should be correct too.

m.hoev gravatar imagem.hoev ( 2014-06-13 04:08:11 -0500 )edit

Can you post the updated configuration that you're now using, as well as the result of running rostopic info /scan

David Lu gravatar imageDavid Lu ( 2014-06-13 12:20:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-17 07:52:08 -0500

m.hoev gravatar image

updated 2014-06-17 07:56:30 -0500

My updated costmap_common_params.yaml is:

map_type: costmap transform_tolerance:
0.2 obstacle_range: 2.5 raytrace_range: 3.0 inflation_radius:
0.25

observation_sources: base_scan

#base_scan_marking: {sensor_frame: base_scan_link,
#                    data_type: PointCloud2,
#                    topic: /base_scan/marking,
#                    expected_update_rate: 0.2,
#                    observation_persistence: 0.0,
#                    marking: true,
#                    clearing: false,
#                    min_obstacle_height: 0.06,
#                    max_obstacle_height: 2.0}

base_scan: {sensor_frame: laser,
            data_type: LaserScan,
            topic: /scan,
            expected_update_rate: 0.2,
            observation_persistence: 0.0,
            marking: true,
            clearing: true,
            min_obstacle_height: -0.10,
            max_obstacle_height: 2.0}

I think it is running properly now. The result of rostopic info /scan is:

Type: sensor_msgs/LaserScan
Publishers:   * /hokuyo_node (http://J-youBot:XXXXX/)
Subscribers:   * /move_base_node (http://J-youBot:XXXXX/)

The warning stops after receiving info: odom received

edit flag offensive delete link more

Comments

Running properly now --> No more help needed?

David Lu gravatar imageDavid Lu ( 2014-06-17 09:48:28 -0500 )edit

yes, thanks a lot

m.hoev gravatar imagem.hoev ( 2014-06-17 10:39:29 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-05-29 22:45:06 -0500

Seen: 2,670 times

Last updated: Jun 17 '14