Ask Your Question
2

SIGILL, Illegal instruction in libpcl_common.so.1.5.1 from costmap_2d

asked 2013-05-10 01:43:35 -0600

BtbN gravatar image

Since our latest ros fuerte update in ubuntu precise, our navigation crashes. After investigating the issue, we found out that the problem is the costmap_2d node, which crahses with SIGILL, which mean that an illegal assembler instruction was called. We furhter investigated this, and found out, that it's a AVX instruction call in Eigen, called from libpcl in libpcl_common.so.1.5.1 Our ros is running on an intel atom, which does not support avx, so we can't use it anymore.

We tried to build our own version without avx, but failed to find out how to build our own deb to replace the existing one. The avx instructions shouldn't be in there at all, as many CPUs don't support it. The problems started with the ros update on 2nd May.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2013-05-10 12:43:25 -0600

BtbN gravatar image

I managed to hack-fix this for now. All i did was just rebuilding pcl from ros-gbp/pcl-fuerte-release.git on github(debian/fuerte/precise/pcl branch) on the machine it's running on and then simply replacing the libpcl files in /opt/ros/fuerte/lib with the ones i built.

Not a clean fix as it interfers with the package manager, but it works for now and i hope that the next update fixes it.

It looks like cmake checks for the SSE and other cpu capabilitys when it's configuring. So if the buildservers are capable of avx and other extensions, that'd explain how the instructions got in there.

edit flag offensive delete link more

Comments

Clearly, the build farm should not produce binaries that only work on its particular hardware.

joq gravatar imagejoq ( 2013-05-10 12:54:18 -0600 )edit

This also cleared up the issue for me. While a bit hacky, works until the build farm produces a working release.

jarvisschultz gravatar imagejarvisschultz ( 2013-05-12 13:57:15 -0600 )edit

This hack worked for me too

martimorta gravatar imagemartimorta ( 2013-05-14 00:38:15 -0600 )edit

This hack also fixes my problem.

LEinig gravatar imageLEinig ( 2013-05-16 22:56:29 -0600 )edit

This "fix" will disappear the next time you upgrade this package. You should avoid upgrading your packages until it is really fixed in the repo.

joq gravatar imagejoq ( 2013-05-17 05:39:16 -0600 )edit

How did you get the sources? I tried git clone https://github.com.ros-gbp/pcl-fuerte.release.git but there was nothing to compile in the downloaded folder (pcl-fuerte-release)

da-na gravatar imageda-na ( 2013-05-28 00:02:11 -0600 )edit

It's in the debian/fuerte/precise/pcl branch.

BtbN gravatar imageBtbN ( 2013-05-28 00:41:42 -0600 )edit

try git clone -b fuerte-devel https://github.com/ros-perception/perception_pcl.git or download the tar.gz

martimorta gravatar imagemartimorta ( 2013-05-28 00:53:18 -0600 )edit
0

answered 2013-05-10 04:47:55 -0600

joq gravatar image

updated 2013-05-10 06:02:53 -0600

Please open a defect ticket for this issue.

You can include a link to this page.

UPDATE: As @jarvisschultz mentioned, he already opened an issue for this problem, I added a link back to here.

I suspect that the actual bug may lie outside perception_pcl, but that issue should at least get it resolved.

edit flag offensive delete link more

Comments

I am having a possibly related problem. I filed a bug report here, note that this question seems related as well.

jarvisschultz gravatar imagejarvisschultz ( 2013-05-10 05:38:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-05-10 01:43:35 -0600

Seen: 892 times

Last updated: Jun 06 '13