Ask Your Question
2

Compiling PCL (PCL 1.5) in ROS fuerte

asked 2012-06-29 04:11:50 -0500

OliR gravatar image

updated 2014-04-20 14:09:31 -0500

ngrennan gravatar image

I've cloned the PCL sources (for PCL 1.5) from https://github.com/wg-debs/pcl in my ROS_WORKSPACE and renamed it as pcl.

I cannot compile pcl1.5 in my ROS_WORKSPACE. With "$ roscd pcl" my current directory changes to /opt/ros/fuerte/share/pcl which is not in my ROS_WORKSPACE.

I want to just make an executable file i.e. openni_viewer in my ROS_WORKSPACE/pcl/visualization/tools and execute that.

In the CMakeList.txt in the directory "pcl/visualization/tools" there is a instruction for that... PCL_ADD_EXECUTABLE(openni_viewer ${SUBSYS_NAME} openni_viewer.cpp) target_link_libraries(openni_viewer pcl_common pcl_io pcl_kdtree pcl_visualization)

But it is not compiled with $ rosmake pcl (I cannot get a binary executable file from pcl/viaualization/tools/openni_viewer.cpp)

Earler, I used to clone the stack "perception_pcl_addons" to my ROS_PACKAGE_PATH and just $ rosmake pcl_visualization (using previous versions of ROS) which then created a binary executable file openni_viewer.

Do you have any suggestions?

My confituration: ROS fuerte, Ubuntu 11.10

with best regards, oli

edit retag flag offensive close merge delete

Comments

did you get it working? I'm still looking for a solution to compile a ros supported pcl version.

dinamex gravatar image dinamex  ( 2012-08-29 07:05:45 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-06 05:10:38 -0500

joq gravatar image

updated 2012-09-06 05:19:20 -0500

The PCL sources in https://github.com/wg-debs/pcl do not contain a ROS package. That is why roscd cannot find them and rosmake cannot make them.

Those sources were apparently used to create the ros-fuerte-pcl Debian package for the supported Ubuntu versions (Lucid, Oneiric, and Precise). To build them on another system, look inside the Debian rules to see how to build it.

Probably, it looks similar to a normal stand-alone PCL build, but with the USE_ROS parameter set. The following is my best guess:

$ mkdir build
$ cd build
$ cmake .. -DUSE_ROS=1
$ make 
$ sudo make install

Please let us know what actually works for you.

edit flag offensive delete link more
2

answered 2012-06-29 08:41:56 -0500

bhaskara gravatar image

updated 2012-06-29 08:42:21 -0500

You still need to set ROS_PACKAGE_PATH. Do a

$ export ROS_PACKAGE_PATH=/path/to/pcl:$ROS_PACKAGE_PATH 
$ roscd pcl
edit flag offensive delete link more

Comments

Thank you for your answer But I've already set my ROS_PACKAGE_PATH as my private directory and in that directory locate the pcl package.

I set my ROS_PACKAGE_PATH and my ROS_WORKSPACE as follow $ export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH $ export ROS_WORKSPACE=~/ros

OliR gravatar image OliR  ( 2012-07-01 11:13:20 -0500 )edit

And the package "pcl" is in my directory ~/ros/. There are also other stacks and packages. With $ roscd STACK or PACKAGE changes my current directory to ~/ros/STACK or PACKAGE. BUT it is not working only for the "pcl". $ roscd pcl indicate always /opt/ros/fuerte/share. Do u have any idea?

OliR gravatar image OliR  ( 2012-07-01 11:23:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-29 04:11:50 -0500

Seen: 795 times

Last updated: Sep 06 '12