Ask Your Question
1

Husky not sending odometry data [closed]

asked 2013-04-02 06:59:21 -0500

updated 2014-01-28 17:16:00 -0500

ngrennan gravatar image

Hi All,

I am trying to set up SLAM on a Husky A200, and am having some troubles. There is no tf link between /odom and /base_footprint. To fix this, I am using robot_pose_ekf to take the husky's odometry data and publish the transform to tf. This is not working however. After going through robot_pose_ekf's troubleshooting page I have found the the husky is not sending out the odometry data. I can see /encoder when I run rostopic list, but when I run rostopic hz /encoder the cursor just blinks until I cancel the command. I am running dead_reckoning.py to get the odom data, and have edited the robot_pose_efk.launch file to accept /encoder as the odometry topic. If anyone knows why the husky is not sending out the data I need it would be appreciated.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-04-02 11:05:00

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-04-02 11:04:40 -0500

I got it working. It was my own inexperience. I have only ever used the husky using the clearpath_base example.launch file. After rooting around a little I found out that there was in fact a base.launch in the husky_bringup folder. After modifying that a little so that I wouldn't have to specify the port I use every time, it ran well. Then I just had to tweak a few of the launch files to get all of the publishers and subscribers to line up properly, and it started to work.

edit flag offensive delete link more

Comments

Hi, I'm quite new to Ros and I have problems to remap everything correctly to make the odometry work, could you help me a little providing me in which file should I remap the "encoders" to "odom" and how to do it. Thanks

Thibault-Salford gravatar imageThibault-Salford ( 2013-04-18 04:45:06 -0500 )edit

I used the robot_pose_ekf package to remap from encoder to odom. You will need to edit the launch file a little first. In the launch file change the output_frame from odom_combined to odom and at the bottom where it says to remap from odom, change the pr2_base_odometry/odom to encoder.

Icehawk101 gravatar imageIcehawk101 ( 2013-04-18 05:28:36 -0500 )edit

Mmmmm I think I need to know how to link all the frames, I only used a tf_publisher to link them, but what exactly did you put to link the map with odom and odom with base_link? Thanks for the first answer btw

Thibault-Salford gravatar imageThibault-Salford ( 2013-04-19 05:27:45 -0500 )edit

I'm not sure what your application is, but for me map to odom is provided by gmapping. odom to base_link I got using robot_pose_ekf.

Icehawk101 gravatar imageIcehawk101 ( 2013-04-19 07:12:36 -0500 )edit
1

answered 2013-04-02 09:22:30 -0500

bombilee gravatar image

updated 2013-04-02 09:24:59 -0500

If you have Husky A200 running with the computer already setup ROS with it. Make sure the Husky communication light is on(Green when no e-stop/yellow when e-stop), before you try to do anything else. Usually the communication is trigger by the event the Ethernet cable plugin to the computer ( depend on the setup you have) "eth0". If the communication light is on. You should see the data form

rostopic echo /encoder
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-02 06:59:21 -0500

Seen: 1,052 times

Last updated: Apr 02 '13