Navigation stack problem, initial- and goalpose not accepted [closed]

asked 2013-03-29 03:29:27 -0500

funas1 gravatar image

Hello there again

I am trying to run the navigation stack with my own robot. So far i created a map, which worked fine. I followed the navigation tutorial to set up my robot. When I launch the configuration file, everything seems ok, when launching the move_base.launch file I get the warning: The origin for the sensor is at (-0.00, 0.01, 0.00) is out of map bounds. So, the costmap cannot raytrace for it.

But i think this is because I didn't set the initial pose of the robot. When I try to do this in rviz, following the tutorial on using rviz for navigation, my pose doesn't get accepted. The same thing happens to the goal pose. The arrow vanishes and nothing happens, the warning "out of bounds" persists.

When I look at my tf tree it is map->odom->base_link->laser, so this should be ok. I tried to fix this in the past days but didn't achieve anything.

Is there anything I am missing? Maybe you need more infos...

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-12-12 01:16:48.016174