Ask Your Question
0

Error while connecting to Roomba using roomba_500 package

asked 2013-03-05 04:23:55 -0500

Devasena Inupakutika gravatar image

updated 2013-03-06 20:25:53 -0500

As soon as I run -->

rosrun roomba_500_series roomba560_node

it gets connected for a fraction of second and then displays the error message

Error: Could not retrieve sensor packets while connecting roomba with laptop.

Any setting that needs to be done for persistent connection ? Please suggest.

edit retag flag offensive close merge delete

Comments

Please find the details below: 1. Ubuntu 12.04 LTS

  1. ROS groovy

  2. Yes, dmesg is giving results as expected.

  3. FTDI cable

  4. Roomba 500 series. Roomba 560 node.

  5. Yes, i am running roscore first and then rosrun.

Devasena Inupakutika gravatar image Devasena Inupakutika  ( 2013-03-06 21:18:29 -0500 )edit

Details below:

Devasena Inupakutika gravatar image Devasena Inupakutika  ( 2013-03-06 21:18:30 -0500 )edit

I have installed ROS fuerte and checked... It's giving same error --> Couldn't retrieve sensor packets. Please suggest what should be done in case we face with this error on ROS fuerte / electric. I have checked everything again like USB permissions etc.

Devasena Inupakutika gravatar image Devasena Inupakutika  ( 2013-03-08 02:40:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-08 04:01:00 -0500

Devasena Inupakutika gravatar image

There was issue with roomba 521 base's FTDI serial connection due to which it was getting disconnected as soon as it gets connected to roomba. I have tested on two other turtlebots that we have got in lab and everything working fine. Thanks for the help. Can you please accept this and close this as well as other questions that i raised. @Arkapravo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-05 04:23:55 -0500

Seen: 400 times

Last updated: Mar 08 '13