Ask Your Question
0

Turtlebot 2 errors

asked 2013-02-28 22:23:08 -0500

prasanna.kumar gravatar image

updated 2013-03-03 20:58:05 -0500

Updated: I removed everything from the turtlebot laptop and installed Ubuntu 12.04, installed ros-groovy-desktop and went through debs installation for the TurtleBot.

  1. I do not get errors with bringup now but I get this warning

    process[app_manager-11]: started with pid [6649] [WARN] [WallTime: 1362386890.272856] Battery : unable to check laptop battery info [/proc/acpi/battery/BAT0 does not exist] [WARN] [WallTime: 1362386890.277911] Battery : unable to check laptop battery state [/proc/acpi/battery/BAT0 does not exist].

  2. Now, the dashboard looks like this

image description

With tele-op, it is still the same. I am not able to move it around. The controls do not work.

The kuboki base doesn't seem to be recognized. Why is that ? Is there a mistake I am doing ?

Thanks, Prasanna.

edit retag flag offensive close merge delete

Comments

Can you you see the robot green LED? Sorry, I know this sounds like a stupid question, but Kobuki has a switch to change between firmware updates (no LED) and normal running. Maybe your switch is on "download" mode.

jorge gravatar image jorge  ( 2013-03-04 12:07:33 -0500 )edit

And another basic thing to check is whether port /dev/kobuki exists when the robot is plugged (don't need to be on)

jorge gravatar image jorge  ( 2013-03-04 12:08:41 -0500 )edit
1

The warning is probably because you are using a different laptop than the default the turtlebot is configured for. There is some information about netbook batteries on the wiki: http://ros.org/wiki/turtlebot/Tutorials/groovy/Netbook%20Battery%20Setup

Daniel Stonier gravatar image Daniel Stonier  ( 2013-03-04 12:58:19 -0500 )edit

@jorge The switch is in "operation" mode only and /dev/kobuki does not exist. What may be the problem ?

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-04 20:43:22 -0500 )edit

@Daniel Stonier under /proc/acpi there is nothing named battery. So basically there is no /proc/acpi/battery.

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-04 23:59:20 -0500 )edit

Did you execute this command after installation? rosrun kobuki_ftdi create_udev_rules (you will need root password; and upgrade ros-groovy-kobuki if the script is missing)

jorge gravatar image jorge  ( 2013-03-05 11:58:09 -0500 )edit

@Daniel Stonier Thanks! I guess that should work once <param> tag bug is fixed. And, I am sorry if this sounds too naive, how do I edit a ros wiki page?

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-06 04:02:45 -0500 )edit

@Daniel Stonier I tried setting the battery to /sys/class/power_supply/BAT0 but now I am getting a warning tha /sys/class/power_supply/BAT1/info is missing.

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-07 20:52:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-06 02:50:09 -0500

Daniel Stonier gravatar image

Is http://askubuntu.com/questions/214379/where-did-proc-acpi-battery-bat0-xxx-go-in-12-10 relevant for you? If that works, update the battery setup wiki page with a hint and ticket us at https://github.com/turtlebot/turtlebot/issues?state=open

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-28 22:23:08 -0500

Seen: 2,180 times

Last updated: Mar 03 '13