Ask Your Question
0

Cant get data from Create robot - Error reading from SCI port ttyUSB0

asked 2011-11-28 11:20:44 -0500

chopchop gravatar image

updated 2011-11-28 12:31:17 -0500

Hi all,

in the turtlebot-dashboard all the sensors are Stale apart from the Laptop battery one, and when I do roslaunch turtlebot_bringup minimal.launch I get the code below. Weird thing is it worked perfectly yesterday; then I played with Kinect drivers and then it stopped working. So I did a fresh ubuntu install on the turtlebot laptop but I still get the same!

Turtlebot is on and light is green by the way so there is plenty of power. I've also checked /etc/udev/rules.d/52-turtlebot.conf and it has read and write rules (666). I also checked dmesg and the turtlebot is on ttyUSB0. I can also see the leds on the irobot cable light up in both directions so there is traffic.

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.1.15:49038/

SUMMARY
========

PARAMETERS
 * /use_sim_time
 * /robot_pose_ekf/sensor_timeout
 * /diagnostic_aggregator/analyzers/sensors/path
 * /robot_pose_ekf/imu_used
 * /robot_pose_ekf/odom_used
 * /robot/name
 * /diagnostic_aggregator/analyzers/mode/timeout
 * /diagnostic_aggregator/analyzers/sensors/timeout
 * /diagnostic_aggregator/analyzers/power/type
 * /turtlebot_node/update_rate
 * /diagnostic_aggregator/analyzers/power/timeout
 * /diagnostic_aggregator/analyzers/mode/type
 * /diagnostic_aggregator/analyzers/digital_io/path
 * /diagnostic_aggregator/analyzers/digital_io/timeout
 * /rosdistro
 * /robot_description
 * /diagnostic_aggregator/base_path
 * /robot_pose_ekf/freq
 * /app_manager/interface_master
 * /robot_pose_ekf/vo_used
 * /diagnostic_aggregator/analyzers/sensors/type
 * /diagnostic_aggregator/analyzers/digital_io/startswith
 * /diagnostic_aggregator/analyzers/power/path
 * /robot_pose_ekf/output_frame
 * /diagnostic_aggregator/analyzers/mode/path
 * /diagnostic_aggregator/analyzers/digital_io/type
 * /diagnostic_aggregator/analyzers/mode/startswith
 * /rosversion
 * /diagnostic_aggregator/pub_rate
 * /robot_state_publisher/publish_frequency
 * /diagnostic_aggregator/analyzers/sensors/startswith
 * /diagnostic_aggregator/analyzers/power/startswith
 * /turtlebot_node/bonus
 * /robot/type
 * /robot_pose_ekf/publish_tf

NODES
  /
    appmaster (app_manager/appmaster)
    app_manager (app_manager/app_manager)
    turtlebot_node (turtlebot_node/turtlebot_node.py)
    turtlebot_laptop_battery (turtlebot_node/laptop_battery.py)
    robot_state_publisher (robot_state_publisher/state_publisher)
    diagnostic_aggregator (diagnostic_aggregator/aggregator_node)
    robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)

ROS_MASTER_URI=http://192.168.1.15:11311

core service [/rosout] found
process[appmaster-1]: started with pid [14445]
process[app_manager-2]: started with pid [14446]
process[turtlebot_node-3]: started with pid [14447]
process[turtlebot_laptop_battery-4]: started with pid [14448]
process[robot_state_publisher-5]: started with pid [14449]
process[diagnostic_aggregator-6]: started with pid [14450]
process[robot_pose_ekf-7]: started with pid [14451]
Unhandled exception in thread started by <bound method XmlRpcNode.run of <roslib.xmlrpc.XmlRpcNode object at 0xf851d0>>
Traceback (most recent call last):
  File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 194, in run
    self._run()
  File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 217, in _run
    self.server = ThreadingXMLRPCServer((bind_address, port), log_requests)
  File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 97, in __init__
    SimpleXMLRPCServer.__init__(self, addr, SilenceableXMLRPCRequestHandler, log_requests)
  File "/usr/lib/python2.6/SimpleXMLRPCServer.py", line 539, in __init__
    SocketServer.TCPServer.__init__(self, addr, requestHandler, bind_and_activate)
  File "/usr/lib/python2.6/SocketServer.py", line 400, in __init__
    self.server_bind()
  File "/usr/lib/python2.6/SocketServer.py", line 411, in server_bind
    self.socket.bind(self.server_address)
  File "<string>", line 1, in bind
socket.error: [Errno 98] Address already in use
turtlebot_apps.installed
loading installation data for [turtlebot_apps.installed]
[INFO] [WallTime: 1322529211.211220] Starting app manager for turtlebot
[INFO] [WallTime: 1322529211.301508] Waiting ...
(more)
edit retag flag offensive close merge delete

Comments

Could you post the information in the log file mentioned in the error.
karthik gravatar imagekarthik ( 2011-11-28 11:54:00 -0500 )edit
Thanks I've edited the question
chopchop gravatar imagechopchop ( 2011-11-28 12:31:52 -0500 )edit
I ran dmesg and it confirmed that the turtlebot is connected to ttyUSB0, which is the one the minimal.launch is looking for it; so I reckon it should be ok 'usb 2-1: FTDI USB Serial Device converter now attached to ttyUSB0'
chopchop gravatar imagechopchop ( 2011-11-28 13:11:41 -0500 )edit
I presume It should be either the permissions or the hardware. If not lets wait for some one to share their thoughts.
karthik gravatar imagekarthik ( 2011-11-28 13:17:27 -0500 )edit
1
Try setting the permissions to ttyUSB* and check it this works.
karthik gravatar imagekarthik ( 2011-11-28 13:18:56 -0500 )edit
I did sudo chmod a+rw /dev/ttyUSB0 but still no luck :-(
chopchop gravatar imagechopchop ( 2011-11-28 13:33:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-06 14:43:04 -0500

chopchop gravatar image

turned out my cable was faulty...

edit flag offensive delete link more

Comments

How did you discover that your cable was faulty?

tgilmour gravatar imagetgilmour ( 2016-02-10 14:03:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-28 11:20:44 -0500

Seen: 1,632 times

Last updated: Dec 06 '11