Ask Your Question
0

[solved] Creation of publisher failed: nav_msgs - turtlebot3

asked 2019-02-02 18:24:45 -0500

nsdolic gravatar image

updated 2019-02-18 21:01:22 -0500

Hi everyone- I keep getting "Creation of publisher failed: nav_msgs" on my turtlebot3 after firmware and software upgrade per these instructions:

https://discourse.ros.org/t/announcin...

Here is more details.

[  ] file name      : burger.opencr 
[  ] file size      : 178 KB
[  ] fw_name        : burger 
[  ] fw_ver         : 1.2.2 
[OK] Open port      : /dev/ttyACM0
[  ]
[  ] Board Name     : OpenCR R1.0
[  ] Board Ver      : 0x17020800
[  ] Board Rev      : 0x00000000
[OK] flash_erase    : 0.92s
[OK] flash_write    : 1.27s 
[OK] CRC Check      : 12206B2 12206B2 , 0.006000 sec
[OK] Download 
[OK] jump_to_fw 

ns@nsr:~$ roslaunch turtlebot3_bringup turtlebot3_robot.launch
... logging to /home/ns/.ros/log/a8257316-2746-11e9-ab54-1c3e845e1831/roslaunch-nsr-1867.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.1.229:44700/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /turtlebot3_core/baud: 115200
 * /turtlebot3_core/port: /dev/ttyACM0
 * /turtlebot3_core/tf_prefix: 
 * /turtlebot3_lds/frame_id: base_scan
 * /turtlebot3_lds/port: /dev/ttyUSB0

NODES
  /
    turtlebot3_core (rosserial_python/serial_node.py)
    turtlebot3_diagnostics (turtlebot3_bringup/turtlebot3_diagnostics)
    turtlebot3_lds (hls_lfcd_lds_driver/hlds_laser_publisher)

ROS_MASTER_URI=http://192.168.1.217:11311

process[turtlebot3_core-1]: started with pid [1876]
process[turtlebot3_lds-2]: started with pid [1877]
process[turtlebot3_diagnostics-3]: started with pid [1878]
[INFO] [1549152037.827495]: ROS Serial Python Node
[INFO] [1549152037.913299]: Connecting to /dev/ttyACM0 at 115200 baud
[INFO] [1549152040.102183]: Note: publish buffer size is 1024 bytes
[INFO] [1549152040.103930]: Setup publisher on sensor_state [turtlebot3_msgs/SensorState]
[INFO] [1549152040.129122]: Setup publisher on firmware_version [turtlebot3_msgs/VersionInfo]
[INFO] [1549152040.257314]: Setup publisher on imu [sensor_msgs/Imu]
[INFO] [1549152040.277802]: Setup publisher on cmd_vel_rc100 [geometry_msgs/Twist]
[ERROR] [1549152040.316294]: Creation of publisher failed: nav_msgs
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/ns/catkin_ws/src
ROS path [2]=/opt/ros/kinetic/share
[INFO] [1549152040.336951]: Setup publisher on joint_states [sensor_msgs/JointState]
[INFO] [1549152040.373583]: Setup publisher on battery_state [sensor_msgs/BatteryState]
[INFO] [1549152040.595584]: Setup publisher on magnetic_field [sensor_msgs/MagneticField]
the rosdep view is empty: call 'sudo rosdep init' and 'rosdep update'
[INFO] [1549152042.324852]: Setup publisher on /tf [tf/tfMessage]
[INFO] [1549152042.764271]: Note: subscribe buffer size is 1024 bytes
[INFO] [1549152042.766080]: Setup subscriber on cmd_vel [geometry_msgs/Twist]
[INFO] [1549152043.224508]: Setup subscriber on sound [turtlebot3_msgs/Sound]
[INFO] [1549152043.571293]: Setup subscriber on motor_power [std_msgs/Bool]
[INFO] [1549152043.923863]: Setup subscriber on reset [std_msgs/Empty]
[WARN] [1549152044.148519]: Failed to get param: timeout expired
[INFO] [1549152044.151944]: Setup TF on Odometry [odom]
[INFO] [1549152044.155266]: Setup TF on IMU [imu_link]
[INFO] [1549152044.158587]: Setup TF on MagneticField [mag_link]
[INFO] [1549152044.161943]: Setup TF on JointState [base_link]
[INFO] [1549152044.169610]: --------------------------
[INFO] [1549152044.172820]: Connected to OpenCR board!
[INFO] [1549152044.176166]: This core(v1.2.2) is compatible with TB3 Burger
[INFO] [1549152044.179435]: --------------------------
[INFO] [1549152044.182837]: Start Calibration of Gyro
[INFO] [1549152046.693941]: Calibration End
[ERROR] [1549152046.711699]: Tried to publish before configured, topic id 129
[INFO] [1549152046.723071]: Setup publisher on sensor_state [turtlebot3_msgs/SensorState]
[INFO] [1549152046.729636]: Setup publisher on firmware_version [turtlebot3_msgs/VersionInfo]
[INFO] [1549152046.736269]: Setup publisher on imu [sensor_msgs/Imu]
[INFO] [1549152046.743177]: Setup publisher on cmd_vel_rc100 [geometry_msgs ...
(more)
edit retag flag offensive close merge delete

Comments

I assume that you could somthing wrong to add publisher on your code.

Can you attach your code?

Darby Lim gravatar imageDarby Lim ( 2019-02-06 19:00:26 -0500 )edit

I launched roscore on my Laptop running Ubunutu 16.04. Then I login to my turtlebot (RaspberryPi 3b (no plus)) and run following:

$ roslaunch turtlebot3_bringup turtlebot3_robot.launch

The code for turtlebot3_launch is in updated description above.

Is this what you are looking for?

nsdolic gravatar imagensdolic ( 2019-02-06 20:43:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-18 20:59:40 -0500

nsdolic gravatar image

updated 2019-02-18 21:00:54 -0500

For everyone else - I found what the problem was. I did not have nav_msgs package installed. By downloading it from github into src folder and re-running catkin_make on turtlebot3, the problem was solved. This issue can be closed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-02-02 18:24:45 -0500

Seen: 234 times

Last updated: Feb 18