Ask Your Question
1

turtlebot_bringup error - invalid <param> tag [closed]

asked 2013-03-05 05:33:41 -0500

prasanna.kumar gravatar image

I installed turtlebot packages from debs. When I run minimal.launch I get the following error

while processing /opt/ros/groovy/stacks/turtlebot/turtlebot_bringup/launch/includes/_robot.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: no such command [/opt/ros/groovy/share/xacro/xacro.py '/opt/ros/groovy/stacks/turtlebot/turtlebot_description/robots/kobuki_hexagons_kinect.urdf.xacro']. 

Param xml is <param command="$(arg urdf_file)" name="robot_description"/>

I am getting this error after running ubuntu updates this afternoon. I did not get it before the update. Is anyone else getting the same error ?

Thanks,

Prasanna

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by prasanna.kumar
close date 2013-03-11 08:56:03

Comments

I never update Ubuntu. This helps a lot ;-)

Chik gravatar image Chik  ( 2013-03-05 17:12:34 -0500 )edit

I have the same error than you, can you keep me up to date if you solve the problem or if a bug fix is released ? Thanks !

CarolineQ gravatar image CarolineQ  ( 2013-03-05 23:14:21 -0500 )edit

@CarolineQ Your advice to update Ubuntu, wasn't it ;) Sure I ll update..

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-05 23:34:49 -0500 )edit

@prasanna It works for me the first time I did it... But not this time ! Sorry !

CarolineQ gravatar image CarolineQ  ( 2013-03-06 00:38:32 -0500 )edit

New version of xacro has been released yesterday (now version 1.7.3). Download and test it to see if it solves your problem.

bit-pirate gravatar image bit-pirate  ( 2013-03-06 11:46:06 -0500 )edit

I downloaded a new version of xacro doing : "sudo apt-get update" and then "sudo apt-get install ros-groovy-xacro" and it works fine for me now, even with the roslaunch command.

CarolineQ gravatar image CarolineQ  ( 2013-03-06 20:55:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-05 12:20:24 -0500

bit-pirate gravatar image

You are probably hitting the bug in the new version of xacro, which has been introduced when catkinizing it.

Have a look at this ticket for more details: https://github.com/ros/xacro/issues/1

The bug fix should soon be pushed to public.

Please report back, if you are still having issues after the update.

edit flag offensive delete link more

Comments

Guys, I'm sorry to inform you that you need to wait a bit longer for a bug fix. The bug fix in xacro release 1.7.3 only solves the problem of 'rosrun xacro xacro.py ...', but not the roslaunch issue. Follow this ticket for more details: https://github.com/ros/xacro/issues/2

bit-pirate gravatar image bit-pirate  ( 2013-03-06 12:33:32 -0500 )edit

@bit-pirate I installed the new xacro release and now the roslaunch works fine except for the laptop battery warning which I have described here - http://answers.ros.org/question/56704/turtlebot-2-errors/?comment=57279#comment-57279

prasanna.kumar gravatar image prasanna.kumar  ( 2013-03-07 21:00:05 -0500 )edit

@prasanna.kumar Thanks for the info. Just triggered my updates ... PS: Since your question/problem looks to be answered/solved, please mark it accordingly. Thank you!

bit-pirate gravatar image bit-pirate  ( 2013-03-10 13:57:27 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2013-03-05 05:33:41 -0500

Seen: 2,379 times

Last updated: Mar 05 '13