ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Roomba 500 series installation problem

asked 2012-02-16 01:11:03 -0500

cg gravatar image

Dear all,

I am trying to install roomba_500_series in a fresh installation of Ubuntu 11.10 oneiric, which comprises the laptop.

The problem I am facing is that the Source: svn no longer works.

Can someone point me out to the correct source?



edit retag flag offensive close merge delete

6 Answers

Sort by » oldest newest most voted

answered 2012-02-16 01:28:17 -0500

Lorenz gravatar image

updated 2012-02-16 03:07:16 -0500

In general, it always helps to copy-paste complete error messages. 'no longer works' is not really informative. See here for guidelines.

Here at TUM, we also have a couple of EU turtlebots and decided not to use the roomba_500_series node because it has some problems that are really critical for us (e.g. not having a watchdog to stop the robot when no command is received for some time, different topic layout than the original turtlebot, ...). Instead, we made a few patches to turtlebot_node to make it work with the roombas. The patches are already upstream and should be in the newest release of the turtlebot stack. You can bring the robot up by using this launch file:

  <node pkg="turtlebot_node" type="" name="turtlebot_node" output="screen">
      robot_type: roomba
      publish_tf: true
      has_gyro: false

You can also change the minimal.launch file in the package turtlebot_bringup to set the above node parameters. But don't forget to remove robot_pose_ekf in that case since the EU turtlebots don't have a gyro Then Willow Garage's original turtlebot apps should all work.

EDIT: Links to our patches:

edit flag offensive delete link more


Dear Lorenz, I also belong in TUM. Which is your Institute?

cg gravatar image cg  ( 2012-02-16 02:56:45 -0500 )edit

Computer science, our group is the Intelligent Autonomous Systems Group (

Lorenz gravatar image Lorenz  ( 2012-02-16 03:08:23 -0500 )edit

these patches are released in turtlebot 0.9

mmwise gravatar image mmwise  ( 2012-02-16 07:05:27 -0500 )edit

answered 2013-03-28 19:27:00 -0500

AFAIK, the roomba_robot package works just fine ! I used the Roomba 500 series drivers on a Roomba 560 robot, details can be found here --

edit flag offensive delete link more

answered 2012-02-16 03:22:45 -0500

DrBot gravatar image

Never mind, Lorenz, I just found the robot types file. Danke.

edit flag offensive delete link more


I am not getting the electric stack to work. I am getting both a baud rate error and a complaint about the laptop battery being in Ma instead of Mw - is this some EU standard;-) ?

DrBot gravatar image DrBot  ( 2012-02-16 05:47:24 -0500 )edit

answered 2012-02-17 04:00:28 -0500

DrBot gravatar image

I spent a couple of hours yesterday trying to get the electric stacks to work. I got the latest releases for electric, turtlebot-robot, turtlebot-viz. While I got the diamond back stacks to work (teleop, Dashboard) with the only change being the baud rate in the driver section, I couldn't get any part of the electric stacks to work. I did change the baud rate in the electric stacks.

In using the minimal.launch or the launch file suggested by Lorenz, none of the functionality is there. There are SCI errors, the laptop battery can't be read, the diagnostics fail. On either launch, the dash board that comes up is entirely greyed out. I would guess that the baud rate is not being accounted for, but that doesn't explain why it can't read the laptop battery.

So I am falling back to diamondback to continue my Turtlebot EU development.

edit flag offensive delete link more


We noticed that odometry on the roombas is really bad, just changing the baud rate might cause problems there. After the next release of the turtlebot stack, it should be fully compatible to the EU flavor. minimal.launch should definitely work. SCI errors should be gone after patch #121 (link above)

Lorenz gravatar image Lorenz  ( 2012-02-19 23:03:02 -0500 )edit

answered 2012-02-16 01:24:28 -0500

DrBot gravatar image

Try the latest electric version - this is supposed to work better. Especially since the diamondback stacks didn't account for differences between the icreate and 500 series hardware differences.

edit flag offensive delete link more

answered 2012-02-16 02:51:49 -0500

DrBot gravatar image

Lorenz, I like your suggestion - This is a good idea - I am hoping robot_type roomba figures out the proper baud rate for the sci interface, and there is a robot type create or turtle,

If using the turtlebot distribution on a 500 series, you need to change the SCI baud rate. In the file change self.sci from 57600 to 115200. I had to do this for my home built interface cable which used a Freeduino Bib.

Also - what is TUM?

edit flag offensive delete link more


We tested our patches over a few weeks and they seem to be fine. Of course, we added an option for setting the baud rate. We also had to patch the sensor-data reader and handling of odometry. I'll add links to the tickets in my answer. TUM = Technische Universität München

Lorenz gravatar image Lorenz  ( 2012-02-16 02:58:05 -0500 )edit

Question Tools



Asked: 2012-02-16 01:11:03 -0500

Seen: 1,588 times

Last updated: Mar 28 '13