Ask Your Question

How to install and use Roomba_500_series stack?

asked 2011-09-14 17:36:28 -0500

kleekru gravatar image

There are no tutorials for this stack but I would like to know what it does and how to install.

I have turtlebot installed on a laptop connected to a Roomba with a serial SCI. My first step is to get teleop going. Help please.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted

answered 2011-09-14 21:11:35 -0500

Lorenz gravatar image

The stack is actually called roomba_robot and roomba_500_series is a package in it. You just need to check out the stack repository and add the directory to ROS_PACKAGE_PATH. The repository seems to be an SVN repository, so you can get it by:

svn co

I actually prefer using rosinstall for managing my ROS_PACKAGE_PATH. To use it, you can install/update rosinstall by executing:

sudo apt-get install python-setuptools
sudo easy_install -U rosinstall

Then create a rosinstall file for roomba_robot:

roslocate info roomba_robot > ~/roomba-robot.rosinstall

Now create an overlay of your rosinstallation with roomba_robot added:

rosinstall ~/ros_roomba /opt/ros/electric ~/roomba-robot.rosinstall

Now edit your ~/.bashrc and replace the line

source /opt/ros/electric/setup.bash


source ~/ros_roomba/setup.bash

Make sure to open a new terminal or execute the above source command by hand. Now you should be able to rosmake roomba_500_series.

edit flag offensive delete link more


I created the "build" directory in the cereal_port package directory and tried running rosmake only on cereal_port and recieved this new error: {------------------------------------------------------------------------------- CMake Error: Could not find cmake module file:/opt/ros/diamondback/stacks/isr-uc-ros-pkg/lse_communication/cereal_port/build/CMakeFiles/CMakeCXXCompiler.cmake -- Check for working C compiler: /usr/bin/gcc CMake Error at /usr/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:22 (FILE): file Internal CMake error when trying to open file: /opt/ros/diamondback/stacks/isr-uc-ros-pkg/lse_communication/cereal_port/build/CMakeFiles/CMakeTmp/testCCompiler.c for writing. Call Stack (most recent call first): CMake Error: Failed to create CMakeList file for /opt/ros/diamondback/stacks/isr-uc-ros-pkg/lse_communication/cereal_port/build/CMakeFiles/CMakeTmp/CMakeLists.txt CMake Error: : System Error: No such file or directory -- Check for working C compiler: /usr/bin/gcc -- broken CMake Error at /usr/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:42 (FILE): file Internal CMake error when trying to open file: /opt ...(more)
kleekru gravatar image kleekru  ( 2011-09-16 17:06:43 -0500 )edit
Previous to the message above I received an error creating the "build" directory as part of the make for cereal_port package. Then I manually added the build directory and tried to run a rosmake on the cereal_port package by itself and received the errors above. Please please please help. It seems like the roomba should be working... I think I'm missing something simple.
kleekru gravatar image kleekru  ( 2011-09-16 18:52:37 -0500 )edit

@Lorenz Very nice ! everything works nicely - but what do I do next ? I have a very basic roomba 561 - no laser - may use ASUS Xtion later. What do I do next to get this moving. I am on ROS Electric.

Arkapravo gravatar image Arkapravo  ( 2012-10-06 20:58:42 -0500 )edit

answered 2011-09-21 20:43:07 -0500

updated 2012-03-22 03:46:24 -0500

If you go to the roomba_500_series webpage you'll notice under dependencies that you also need cereal_port, meaning you'll need to download both roomba_robot and serial_communication stacks.

You can do that using svn as suggested earlier into a folder on your ROS_PACKAGE_PATH, do not download them into your ROS installation stacks folder!!! Take a look at this tutorial I wrote on how to install the software for a Roomba netbook. You can edit the rosinstall file there to meet your requirements. It was created for our lab Roombas so your probably don't need some of the stacks there.

Hope this helps!

edit flag offensive delete link more

answered 2016-11-24 10:59:02 -0500

Markus gravatar image

Hey I also would like to install software for the roomba 521

I have the following error:

..@turtleBot1:~$ svn co : E160013: Unable to connect to a repository at URL '' svn: E160013: '/svn/trunk/unstable/roomba_robot' path not found

Does that mean your code is no longer avilable=?

Is it possible to get it somewhere else?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2011-09-14 17:36:28 -0500

Seen: 1,553 times

Last updated: Nov 24 '16