Ask Your Question
2

Problems using the navigation stack [closed]

asked 2012-10-16 22:07:17 -0500

g.aterido gravatar image

updated 2012-10-17 00:03:50 -0500

Hi

I'm trying to use the navigation stack, but I have some problems.

Well, I've configured the parameters as the tutorial says. Then I use Rviz for setting the estimated position and the goal. Doing that, I can make the robot move, but I get this warning messages in the console:

[ WARN] [1350459884.039970066, 6963.543000000]: Could not get robot pose, cancelling reconfiguration
[ WARN] [1350459887.093712554, 6968.750000000]: Costmap2DROS transform timeout. Current time: 6968.7500, global_pose stamp: 6968.4210, tolerance: 0.3000

I don't know if it's normal to recieve this warnings (I suppose it's not). I think that the reason why I recieve this warnings is because the frequency of my laser scan is only 2 Hz, but I'm not sure.

In addition, the robot is not able to avoid obstacles, and that tells me that I'm missing something.

For more detail, here's my costmap parameters:

local_costmap:
  global_frame: /odom
  robot_base_frame: /base_footprint
  update_frequency: 5.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  height: 6.0
  resolution: 0.2 #0.05

global_costmap:
  global_frame: /map
  robot_base_frame: /base_footprint
  update_frequency: 5.0
  static_map: true

Can anyone give me a clue? Thanks in advance ;-)

I'm on Ubuntu 12.04 and ROS Fuerte.

EDITED: More info. I've set the frequency of the laser to the max (8Hz) and the warning continues.

With rosrun tf tf_monitor I get:

RESULTS: for all Frames

Frames:
Frame: /back_left_wheel published by /robot_state_publisher Average Delay: 0.000126582 Max Delay: 0.006
Frame: /back_right_wheel published by /robot_state_publisher Average Delay: 0.000126582 Max Delay: 0.006
Frame: /base_footprint published by /summit_xl_odometry Average Delay: -0.00904412 Max Delay: 0.001
Frame: /base_link published by /summit_xl_tf_node Average Delay: -0.256207 Max Delay: 0
Frame: /front_left_wheel published by /robot_state_publisher Average Delay: 0.000126582 Max Delay: 0.006
Frame: /front_right_wheel published by /robot_state_publisher Average Delay: 0.000126582 Max Delay: 0.006
Frame: /imu_link published by /robot_state_publisher Average Delay: -0.509563 Max Delay: 0
Frame: /odom published by /amcl Average Delay: 0.0235 Max Delay: 0.081
Frame: /openni_depth_frame published by /summit_xl_tf_node Average Delay: -0.00770476 Max Delay: 0
Frame: /tof_link published by /robot_state_publisher Average Delay: -0.509563 Max Delay: 0

All Broadcasters:
Node: /amcl 8.27301 Hz, Average Delay: 0.0235 Max Delay: 0.081
Node: /robot_state_publisher 88.6508 Hz, Average Delay: -0.288324 Max Delay: 0.006
Node: /summit_xl_odometry 98.4556 Hz, Average Delay: -0.00904412 Max Delay: 0.001
Node: /summit_xl_tf_node 101.597 Hz, Average Delay: -0.00769048 Max Delay: 0
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by g.aterido
close date 2013-02-12 00:05:13

Comments

1

How do you get robot state vector? I had similar problem with navigation, when published odometry too slow. From my experience suffficient rate is round 50 Hz. My laser update rate is 20 Hz.

Peter Listov gravatar imagePeter Listov ( 2012-10-16 23:05:44 -0500 )edit

I have a simulated odometry, that publish the robot information at 100 Hz. I think that the model I use is based on a gazebo plugin, but I'm not sure. But the navigation only uses the laser scan and estimates its position with an AMCL. Thats the reason why I think the problem is the laser frequency

g.aterido gravatar imageg.aterido ( 2012-10-16 23:11:14 -0500 )edit

can you show the results of 'rosrun tf tf_monitor'

weiin gravatar imageweiin ( 2012-10-16 23:41:21 -0500 )edit

Added to the question ;)

g.aterido gravatar imageg.aterido ( 2012-10-17 00:01:48 -0500 )edit
2

increase the tolarence rate, you may decrease the map size

cagatay gravatar imagecagatay ( 2012-10-17 01:30:06 -0500 )edit

The map size is not so big, is 400 x 400 with 0.2m/pixel. And I don't know how to increase the tolerance rate, I dont' know where is this parameter

g.aterido gravatar imageg.aterido ( 2012-10-17 20:16:57 -0500 )edit

Ok, I've found a yaml for a roomba and there's a lot of parameters that I didn't set. Now with all the parameters configured I don't have the warnings and all works better. Tanks! ;)

g.aterido gravatar imageg.aterido ( 2012-10-17 22:27:55 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-10-18 16:15:14 -0500

weiin gravatar image
edit flag offensive delete link more
1

answered 2012-10-21 20:30:21 -0500

g.aterido gravatar image

Hi weiin, this is a comment / answer, so I'll answer you here ;)

Well, I followed those tutorials and only with that I didn't achieve anything. Probably the problem is that I'm new in ROS and I need to learn more.

My main problem was that there were lot of parameters that I wasn't tuning. This links helped me with that:

http://www.ros.org/wiki/base_local_planner

http://www.ros.org/wiki/costmap_2d

http://www.ros.org/wiki/move_base

edit flag offensive delete link more

Comments

I have exactly similar problem, can you please tell where (in terms of files) exactly you have set the parameters. @g.aterido

RB gravatar imageRB ( 2014-01-22 22:14:36 -0500 )edit

Hi, Brian. I'm sorry, but that was a project I was doing long time ago and I don't have those files anymore :( I don't remember exactly how but I solved it by setting the parameters detailed in the links above. In addition you must be careful with the name of the params (run rosparam list to know ...

g.aterido gravatar imageg.aterido ( 2014-02-02 02:56:45 -0500 )edit

... the real name of the params, because the names mentioned in the links may be different from the real ones).

g.aterido gravatar imageg.aterido ( 2014-02-02 02:57:43 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2012-10-16 22:07:17 -0500

Seen: 4,043 times

Last updated: Oct 21 '12