Ask Your Question
1

rgbdslam on fuerte

asked 2012-10-15 21:42:32 -0600

Flavio P. gravatar image

updated 2014-01-28 17:13:57 -0600

ngrennan gravatar image

Good Morning, I'm kind of new with ROS, and I'm trying to compile rgbdslam on my ROS fuerte following this guide:

here's the link

While running "rosdep install rgbdslam_freiburg" I get an error telling me "missing resource rgbdslam". I read somewhere that rgbdslam is still not supported on fuerte and I was wondering if there is any solution to this...can someone help me? Or can someone tell me when fuerte will be supported?

edit retag flag offensive close merge delete

Comments

1

I'm guessing you skipped a step somewhere, e.g. not working in a directory in your ROS_PACKAGE_PATH. Could you edit your answer to include more detail of what you exactly did.

Felix Endres gravatar imageFelix Endres ( 2012-10-17 10:26:57 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-02-19 21:54:45 -0600

Robbiepr1 gravatar image

It seems that octomap_server can not be resolved automatically by rosdep install. To manually install octomap_server execute the following command: sudo apt-get install ros-DISTRO-octomap-mapping (where DISTRO is your ROS distribution, i.e. fuerte). After octomap is installed, run rosdep install again to resolve the other dependencies.

edit flag offensive delete link more

Comments

Unfortunately, there seems to be no rule for ros-fuerte-octomap-mapping, to make it rosdep-able

Felix Endres gravatar imageFelix Endres ( 2013-02-20 21:42:25 -0600 )edit
0

answered 2013-04-16 11:08:12 -0600

tfoote gravatar image

You need to have ROS_DISTRO=fuerte set to resolve a ROS package as fuerte.

edit flag offensive delete link more
-1

answered 2013-02-12 15:10:35 -0600

nehock gravatar image

I am getting the issue as well followed BOTH - .....GRRRRRRRRRRRRRRRwww.rosGRRRRRrg wiki GRRRRRrgbdslam AND - .....wiki grrrrrrrrROS Tutorials InstallingandConfiguringROSEnvironment

I have reinstalled ubuntu and ros THRRE TIMES HERE....

I do - rosws init ~/fuerte_workspace /opt/ros/fuerte sudo apt-get install python-rosinstall svn co htGRRRRRRRRRRtp:/GRRRRRRR/alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg rosws set ~/fuerte_workspace/rgbdslam_freiburg source ~/fuerte_workspace/setup.bash roscd rgbdslam gets me to - ~/groovy_workspace/rgbdslam_freiburg/rgbdslam$

rosdep update gets me -

rosdep update reading in sources list data from /etc/ros/rosdep/sources.list.d Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/rosdep/gentoo.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/rosdep/base.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/rosdep/python.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/rosdep/ruby.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/releases/fuerte.yaml Hit htGRRRRRRRtps://github.com/ros/rosdistro/raw/master/releases/groovy.yaml updated cache in /home/nehock/.ros/rosdep/sources.cache

rosdep install rgbdslam_freiburg gets me -

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rgbdslam: Missing resource octomap_server ROS path [0]=/opt/ros/groovy/share/ros ROS path [1]=/home/nehock/groovy_workspace/rgbdslam_freiburg ROS path [2]=/home/nehock/fuerte_workspace/rgbdslam_freiburg ROS path [3]=/opt/ros/groovy/share ROS path [4]=/opt/ros/groovy/stacks

I know better than proceed cause I have fresh installed three times and getting same results - I am using groovy right now ( which ain't turning out so grrovy ) and also tried twice with fuerte....I am NOT using catskin crap because the tutorial was written for fuerte and rosbuild and who knows how to create the workspace using the two tutorials...

Anyway any help would be appreciated here as well....

edit flag offensive delete link more

Comments

1

Please don't post a question as an answer in another thread - make a new thread. And please post a legible question. I wouldn't read it in the form above.

Felix Endres gravatar imageFelix Endres ( 2013-02-14 01:58:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-15 21:42:32 -0600

Seen: 1,401 times

Last updated: Feb 19 '13