Ask Your Question
0

Error Installing ROS indigo on ubuntu 15.10

asked 2015-10-30 08:23:53 -0500

uzair gravatar image

updated 2015-10-30 08:26:27 -0500

Hi,

I am trying to install ROS indigo on Ubuntu 15.10. I am following the tutorials given here:

 http://wiki.ros.org/indigo/Installation/Ubuntu

When I enter the command

 sudo apt-get install ros-indigo-desktop-full

I get the error

"Unabe to locate package ros-indigo-desktop-full"

I thought there was something wrong with sources.list file but when I opened it in gedit, the restricted, universe , and multiverse lines are already uncommented. I managed to follow all the steps from 1.1 to 1.4 up until i had to enter

  sudo apt-get install ros-indigo-desktop-full

Which gives me the error mentioned above. Please advise!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2015-10-30 09:29:59 -0500

Akif gravatar image

In installation page of the wiki, it states;

Setup your computer to accept software from packages.ros.org . ROS Indigo ONLY supports Saucy (13.10) and Trusty (14.04) for debian packages.

Therefore you may not be able to install debian packages on 15.10

edit flag offensive delete link more

Comments

http://answers.ros.org/question/22006... The answer on this post says "You can always try building ROS from source if you are stuck on 15.10.". Do you know what this means?

uzair gravatar image uzair  ( 2015-10-30 11:16:36 -0500 )edit

As it tells in that answer, instead on installing ROS using debian package, you can download the source code and build packages on your operating system. Details are here: http://wiki.ros.org/indigo/Installati...

Akif gravatar image Akif  ( 2015-10-30 13:51:39 -0500 )edit

I've succeeded building some part of ROS Indigo on 15.10, That doesn't mean anything will work, but at least the core stuff works. If you'd need to satisfy some dependency that doesn't have a package in 15.10, you may try playing with /etc/ros/rosdep/sources.list.d and create your own dep mapping.

peci1 gravatar image peci1  ( 2015-12-18 01:53:35 -0500 )edit
0

answered 2016-03-12 05:50:49 -0500

I managed to build ROS jade on Ubuntu Willy compiling from sources. Until the moment It works nice:

I installed many packages, among them: navigation rviz gmapping hector_slam rqt

rosinstall_generator gmapping hector_slam navigation rviz rqt ros_comm --rosdistro jade --deps --wet-only --exclude roslisp --tar > my_application.rosinstall

The dependencies I had to install were:

sudo apt-get install libtinyxml-dev lz4 liblz4-dev BZip2 libz2-dev libbz2-dev liburdf-dom-headers-dev libgtest-dev libsdl-image1.2-dev liburdfdom-dev libogre1.8-dev libassimp-dev python-netifaces

Download it

wstool init -j10 src my_application.rosinstall

Compile it

./src/catkin/bin/catkin_make_isolated --devel devel_isolated --devel-space devel_isolated -DCMAKE_BUILD_TYPE=Release

Install it

./src/catkin/bin/catkin_make_isolated --devel devel_isolated --devel-space devel_isolated -DCMAKE_BUILD_TYPE=Release --install

edit flag offensive delete link more
0

answered 2016-03-13 03:03:14 -0500

uzair gravatar image

Thank you for all the answers. I managed to fix my problem by replacing Ubuntu 15.10 with Ubuntu 14.10 Trusty. Everything works well now. Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-30 08:23:53 -0500

Seen: 3,698 times

Last updated: Mar 13 '16