Ask Your Question
0

unable to find install package

asked 2011-04-14 17:48:51 -0500

Dave Everett gravatar image

I have been attempting to install diamondback.

I enter "sudo apt-get install ros-diamondback-desktop-full"

and get

"unable to locate package ros-diamondback-desktop-full"

I am completely new to linux, so any help would be greatly appreciated

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-04-14 17:52:15 -0500

Eric Perko gravatar image

After adding the ROS repositories to your apt sources and adding the WillowGarage keys (steps 1.2 and 1.3 of the Ubuntu installation guide), make sure you also run sudo apt-get update (beginning of step 1.4).

sudo apt-get update will instruct apt to refresh it's list of available software to take into account the fact that you just added new repositories.

After this, you should be able to run sudo apt-get install ros-diamondback-desktop-full with no problems.

edit flag offensive delete link more
1

answered 2011-04-14 22:30:04 -0500

Dave Everett gravatar image

I just found I needed to update again after enabling universe and multiverse, it is now installing.

Dave

edit flag offensive delete link more
0

answered 2011-04-14 21:40:03 -0500

Dave Everett gravatar image

Thanks Eric, I tried again, going through from scratch with the same result.

The only thing I can think is I am not setting up repositories correctly. The ROS link takes you to ubuntu which gives an overview of that feature but with functionality that does not work the same in Maverick.

I went through to the command line instructions, now I'm even more confused.

If there are just a some command lines I need to enter to setup the repositories, would you be able to enter them into an answer?

Thanks, Dave

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-14 17:48:51 -0500

Seen: 2,549 times

Last updated: Apr 14 '11