Ask Your Question
0

Invalid roslaunch XML syntax: not well-formed

asked 2016-09-11 19:41:30 -0500

rdhn gravatar image

I am trying to launch several launch files from a main launch file. I can successfully call one of the launch files from my main launch file. Like this.

http://answers.ros.org/question/42814...

But I fail at calling the other two. The launch file that I can successfully call runs just a single node. No arguments. But the other two launch files that I fail calling have a bunch of arguments which I feel should be passed inside of the "include" tag?

One of them is the launch file for the Kinova Jaco arm and the other one is a launch file that has all the perception functionalities in it.

I am new to xml files and need help with this.
Please ask/comment if you have questions and I guarantee to respond quickly.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-11 21:17:38 -0500

ahendrix gravatar image

Without seeing your launch files, I can't help much with your launch file syntax.

The best advice I can give is for you to read the error messages carefully, and note that an error early in your XML file can cause errors later in the file, so start with the first error message and fix them one at a time.

The most common errors are forgetting to close your tags, or forgetting to close your parentheses. Each tag <foo> needs a matching close tag: </foo> (or use the self-closing version: <foo/>).

edit flag offensive delete link more

Comments

I can provide you with the launch file by tomorrow. The files are in my lab desktop. The error that I get is always the same (same as the title of my question) and because of that I cant really tell what I am doing wrong.

rdhn gravatar image rdhn  ( 2016-09-11 23:17:11 -0500 )edit

Below is link to the folder which has the launch files I want to launch from a single launch file. https://drive.google.com/open?id=0B97...

note that the stacking_blocks.launch is my main launch file. I can successfully call teleop_calibration_jaco.launch not the others.

rdhn gravatar image rdhn  ( 2016-09-12 13:28:58 -0500 )edit

I took a quick read through your launch files and I don't see anything that is obviously wrong with them. I still think the best thing you can do is to read your error messages carefully. These error messages usually include the file name, line and column number, so that's a good place to start.

ahendrix gravatar image ahendrix  ( 2016-09-13 16:33:47 -0500 )edit

If you're still having trouble, please edit your question to include the full error message, as suggested in the support guidelines.

ahendrix gravatar image ahendrix  ( 2016-09-13 16:35:02 -0500 )edit

The main launch file runs now because I have copied and pasted the whole of launch files that i want to launch from my main launch file. I really do not know how to call just the launch file from my main launch file. Calling teleop_calibration_jaco.launch works. Others do not work this way!?

rdhn gravatar image rdhn  ( 2016-09-13 16:54:21 -0500 )edit

And the error message is always the same. Same as in the question topic. I do not get line number or file name.

rdhn gravatar image rdhn  ( 2016-09-13 16:55:36 -0500 )edit

Including launch files works. There must be some syntax error in your launch file that is preventing it from working in your specific case. Please copy and paste the full output from roslaunch into your question (the full prompt, the command, all of the initial output, EVERYTHING)

ahendrix gravatar image ahendrix  ( 2016-09-13 21:24:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-11 19:41:30 -0500

Seen: 1,617 times

Last updated: Sep 11 '16