Ask Your Question
0

install individual stack

asked 2012-10-06 03:47:27 -0500

roskidos gravatar image

I try to install individual stack according to guides at link ROS installation

I use this line:

sudo apt-get install ros-fuerte-slam-gmapping

I had already installed Desktop-Full Install and want to install other stacks individually. Specifically, stacks I tried to install: robotino, robotino_kinect, simple_grasping and a few others but all failed

sudo apt-get install ros-fuerte-robotino
sudo apt-get install ros-fuerte-simple-grapsping
sudo apt-get install ros-fuerte-robotino-kinect

errors:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-fuerte-robotino

What might be wrong here?? did I use the commands incorrectly??

edit retag flag offensive close merge delete

Comments

You could try to install via svn(URL can be found in the wiki) or add the url of the source code to the apt-get install command...

Flowers gravatar image Flowers  ( 2012-10-06 10:46:53 -0500 )edit

@Flowers: I've just turned to use Ubuntu for 2 weeks and not sure what svn is. Could you tell me clearer? some code lines for example

roskidos gravatar image roskidos  ( 2012-10-06 19:55:45 -0500 )edit

I think ipso is right! I tried to install another stack with: apt-cache search ros-fuerte-pr2-simulator and it worked so smoothly

roskidos gravatar image roskidos  ( 2012-10-07 06:35:30 -0500 )edit

apt-cache gives you information about packages. For information on svn (subversion), google will probably be helpful.

Lorenz gravatar image Lorenz  ( 2012-10-08 01:29:51 -0500 )edit

@Flowers: thanks for you help!! actually, I finally did it with svn for packages without debian files. simply checkout from svn to download the source files and build it with ccmake or rosmake. That's what I did

roskidos gravatar image roskidos  ( 2012-10-12 20:40:35 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2012-10-08 00:52:16 -0500

Flowers gravatar image

To use svn, first make sure it is installed: sudo apt-get install subversion libapache2-svn then by: svn checkout http://svn.openrobotino.org/robotino-ros-pkg/trunk/robotino /home/ros_workspace/robotino you can download the package(of course you can replace /home/... by any path you want to install the package to, but make sure the path is in ROS_PACKAGE_PATH and ROS_WORKSPACE)..

afterwards you have the files in your folder and can run rosmake robotino...

edit flag offensive delete link more
1

answered 2012-10-08 03:51:08 -0500

mjcarroll gravatar image

updated 2012-10-09 13:43:48 -0500

I would use the excellent rosws tool. If you have followed the Fuerte installation instructions, you should already have it. This is the ideal way to find packages that aren't available through apt-get.

If not, use the following command:

sudo apt-get install python-rosinstall

You can then do the following:

# Initialize a workspace
rosws init ~/robotino_testing

# Source that workspace
cd ~/robotino_testing && source ./setup.bash

# Merge your OS install
rosws merge /opt/ros/fuerte

# Find the robotino repository and merge it locally
roslocate info robotino | rosws merge -
roslocate info robotino_kinect | rosws merge -
roslocate info simple_grasping | rosws merge -

# Update your workspace
rosws update

Now you can just rosmake the packages that you are interested in using.

edit flag offensive delete link more

Comments

Lorenz gravatar image Lorenz  ( 2012-10-08 04:07:42 -0500 )edit
1

I did not indicate to manage the ROS_PACKAGE_PATH and ROS_WORKSPACE by hand, it is part of the first tutorials to create a ROS_WORKSPACE...it was just additional information because tools like roscd won't find any package which is not part of the ROS_PACKAGE_PATH ^^

Flowers gravatar image Flowers  ( 2012-10-08 15:21:26 -0500 )edit

@Flowers, sorry! You are correct, and I have modified my answer.

mjcarroll gravatar image mjcarroll  ( 2012-10-09 13:44:15 -0500 )edit
0

answered 2012-10-06 10:38:29 -0500

ipso gravatar image

updated 2012-10-06 10:40:08 -0500

What might be wrong here?? did I use the commands incorrectly??

Not that I can see. It seems package ros-fuerte-robotino just doesn't exist, as far as I can see:

user@comp:~$ apt-cache search ros-fuerte-robotino
user@comp:~$ apt-cache search ros-fuerte-robotino-kinect
user@comp:~$ apt-cache search ros-fuerte-simple-grasping
user@comp:~$

There are Robotino related packets, but they don't seem to have been released as deb packages. See also wiki/openrobotino on the ROS wiki.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-06 03:47:27 -0500

Seen: 671 times

Last updated: Oct 09 '12