Ask Your Question
2

ros beginner tutorials problem

asked 2012-08-16 14:32:21 -0600

Vishnu gravatar image

While trying to execute the command roscd beginner_tutorials or rospack find beginner_tutorials i'm getting a message displaying No such package/stack. plz help

edit retag flag offensive close merge delete

Comments

I also ever met with the same problem! But I always use 'cd' now.

Fighting_bird gravatar imageFighting_bird ( 2016-03-13 03:39:29 -0600 )edit

7 Answers

Sort by » oldest newest most voted
6

answered 2012-08-16 16:52:39 -0600

moyashi gravatar image

Could you try the followings?

1. Launch a terminal.
2. Open ".bashrc". ".bashrc" is at your home directry(/home/(user-name)/.bashrc).
   eg). $gedit .bashrc
3. Check whether there are the following lines or not. If not, add them.
   (
    Assumption:
    1. You use ros electric. If you use other ros versions, change the part "electric".
    2. You made ros_workspace directry at your home directry and created beginner_tutorials package in the directry.
   )
export /opt/ros/electric/setup.bash
export ROS_PACKAGE_PATH=~/ros_workspace:/opt/ros/electric/stacks

*Second line is important. You need to add the directry which includes packages to environment variable.

If roscd still doesn't work well...
1. Go to beginner_tutorials directry.
   eg). cd ~/ros_workspace/beginner_tutorials
2. Type the following command.
   $rosmake
3. Retry "roscd".

edit flag offensive delete link more
2

answered 2013-06-30 09:52:50 -0600

kk gravatar image

Try this : $ source devel/setup.bash It worked for me. (You should have a catkin workspace already created and your package must be inside the workspace)

edit flag offensive delete link more

Comments

This worked for me, thank you! Just have to make sure you're NOT in the ~/catkin_ws/src directory, but rather in the ~/catkin_ws/ directory :)

oswinium gravatar imageoswinium ( 2014-02-10 04:56:19 -0600 )edit
2

answered 2013-04-17 09:48:39 -0600

Ziko gravatar image

Hi,

I have the same problem with groovy distribution. I have first wrote:

$source /opt/ros/groovy/setup.bash

and then:

$rospack depends1 beginner_tutorials

the result is:

Error: no such package beginner_tutorials

The solution for my distrubution of ros is the same?

edit flag offensive delete link more

Comments

2

Please do not post additional questions as "answers". That is not how this forum works.

joq gravatar imagejoq ( 2013-04-17 10:05:50 -0600 )edit
0

answered 2013-11-01 16:52:17 -0600

doudoushuixiu gravatar image

maybe you should run the roscore first

edit flag offensive delete link more

Comments

No, rospack and roscd do not depend on a running roscore.

joq gravatar imagejoq ( 2013-11-02 06:06:23 -0600 )edit
0

answered 2015-02-22 11:59:14 -0600

netstv gravatar image

Hi everyone, I just ran into this problem and found it was my own stupidity and not reading CAREFULLY the tutorial instructions.

I have the distro indigo (found by "echo $ROS_DISTRO").

So I thought I followed the tutorial and I missed the one step... BEFORE you call:

catkin_create_pkg beginner_tutorials std_msgs rospy roscpp

Make sure you are in the ~/catkin_ws/src directory. <- that's the step I missed.

I called catkin_create_pkg from the ~/catkin_ws directory. WRONG... it's looking for it in the src directory.

Anyway, hope this helps someone else...

edit flag offensive delete link more
0

answered 2012-08-16 16:01:05 -0600

joq gravatar image

You need to source the appropriate setup.bash in your shell.

edit flag offensive delete link more
0

answered 2013-10-31 07:54:28 -0600

Nadir gravatar image

I got the same problem and tried all suggested solutions but didn't help. So I created package not in catkin_ws/src but catkin_ws directory and it worked. I'm not very good at Linux, but I think problem is about defining home path while creating ros workspace.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-16 14:32:21 -0600

Seen: 7,987 times

Last updated: Nov 01 '13