Ask Your Question
0

slam_gmapping MappingFromLoggedData out of dual 32-bit range

asked 2011-03-03 19:52:27 -0500

sam gravatar image

updated 2011-03-21 08:29:31 -0500

mmwise gravatar image

Hi, I followed the tutorial doc. http://www.ros.org/wiki/slam_gmapping... When I finished make index success,and began to play it, I found a error reported. I have tried both ubuntu 32,64 bits,and it seems the same problem.

The error message is

 sam@sam-desktop:~/code/ros/slam/mapping$ rosbag play basic_localization_stage.bag 
 [ INFO] [1298639209.074814380]: Opening basic_localization_stage.bag

 Waiting 0.2 seconds after advertising topics... done.

 Hit space to toggle paused, or 's' to step.
 [FATAL] [1298639301.490772364]: Time is out of dual 32-bit      range670987.745222     
 sam@sam-desktop:~/code/ros/slam/mapping$
edit retag flag offensive close merge delete

Comments

I just tried that tutorial with Diamondback on a 64-bit system, and I couldn't replicate your error. Is there anything unusual about your system?
Brian Gerkey gravatar image Brian Gerkey  ( 2011-06-07 21:30:24 -0500 )edit
I use the normal ubuntu 10.10 with Diamondback installation. I didn't find any strange. what I use for installation instruction is "sudo apt-get install ros-diamondback-*"
sam gravatar image sam  ( 2011-06-08 02:24:34 -0500 )edit

I'm having the same issue on 64bit Ubuntu 11.10 with Fuerte. Any luck solving it?

tbernhard gravatar image tbernhard  ( 2012-06-26 09:10:32 -0500 )edit

4 Answers

Sort by » oldest newest most voted
-1

answered 2011-09-02 11:53:58 -0500

kwc gravatar image

no activity > 1 month, closing

edit flag offensive delete link more

Comments

Why you want to close this problem? This problem haven't been solved. I'm still waiting for answer.
sam gravatar image sam  ( 2011-09-02 12:54:11 -0500 )edit
This question is 6 months old. At this point it is very unlikely to be answered. People have already attempted to reproduce your problem and can't, so it's time to let the community to focus on other questions.
kwc gravatar image kwc  ( 2011-09-02 14:32:15 -0500 )edit
So Willow Garage have someone specially focus on trying to answer all the questions?
sam gravatar image sam  ( 2011-09-02 15:32:11 -0500 )edit
from time to time, we try and go through unanswered questions to see if answers can be provided
kwc gravatar image kwc  ( 2011-09-02 16:59:39 -0500 )edit
0

answered 2012-03-21 08:11:01 -0500

Newbie_NXT_KINECT_ROS gravatar image

updated 2012-03-21 08:12:48 -0500

Having the same exact problem.

(Running on Ubuntu 11.10, elctric, 32 bits)

edit flag offensive delete link more
0

answered 2011-04-20 09:49:06 -0500

tyleroar gravatar image

I believe this error is caused by not setting use_sim_time. I think when you are recording the data yourself you would set to false and when downloading a bag you would set to true.

edit flag offensive delete link more

Comments

I run again and make sure I have run "rosparam set use_sim_time true", it appealed the same problem~
sam gravatar image sam  ( 2011-06-06 19:33:27 -0500 )edit
0

answered 2012-03-20 01:59:58 -0500

updated 2012-03-21 09:58:44 -0500

I have the same problem. I'm trying to execute the ar_pose demo from ccny_vision. I've downloaded the dataset as the tutorial explained. And I can't execute the bag file.

I'm using ros-electric in a ubuntu 11.10 Regards

[FATAL] [1332242835.685289221]: Time is out of dual 32-bit range
geus@geus-vaio:/opt/ros/external/full_organization_repositories/ccny_vision/ar_pose/demo$ rosparam set use_sim_time true
geus@geus-vaio:/opt/ros/external/full_organization_repositories/ccny_vision/ar_pose/demo$ rosbag play --clock ./usb_cam_topics_ar_single.bag 
[ INFO] [1332242859.134186718]: Opening ./usb_cam_topics_ar_single.bag
edit flag offensive delete link more

Comments

Thank you for sharing experience,and this experience isn't the answer,so you can comment at the original post.

sam gravatar image sam  ( 2012-03-20 13:03:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-03-03 19:52:27 -0500

Seen: 1,116 times

Last updated: Mar 21 '12