Ask Your Question
3

OSX Fuerte Install Python Error Msg

asked 2012-05-08 16:59:49 -0500

Red24Dog gravatar image

updated 2014-01-28 17:12:15 -0500

ngrennan gravatar image

Following "http://www.ros.org/wiki/fuerte/Installation/OSX/Homebrew", installed "numpy nose" and running "cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF":

CMake Warning at build/cmake/rosunit/rosunit-extras.cmake:17 (message): add_pyunit() is deprecated. For Python tests, use add_nostests() instead.

and further down:

CMake Error at /usr/local/Cellar/cmake/2.8.7/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE): Could NOT find wxWidgets (missing: wxWidgets_FOUND)

is it necessary to also install gdal? And if so from where?

Suggestions to fix?

edit retag flag offensive close merge delete

Comments

1

Yes, I got the python warnings too ... they aren't an issue.

Kevin gravatar image Kevin  ( 2012-05-08 17:44:55 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-05-08 17:43:06 -0500

Kevin gravatar image

Try these instructions ... I think the ones you are following are a little out dated. These worked for me.

edit flag offensive delete link more

Comments

Followed your instructions to 1.3.1 Layer 1 with Ok completion until running both Debian & non-Debian DCMAKE commands-not sure which one. Same result "CMake error at rx/tools/CMakeLists.txt.wx-enhanced swig binary not found. Aborting"

Red24Dog gravatar image Red24Dog  ( 2012-05-08 19:01:11 -0500 )edit
1

OSX is not Debian (linux) so use the the not Debian option. Did you install swig??

Kevin gravatar image Kevin  ( 2012-05-09 02:23:12 -0500 )edit

I did not explicitly. Did that install get missed in the scripts? What package should I use?

Red24Dog gravatar image Red24Dog  ( 2012-05-09 04:45:29 -0500 )edit

It looks like ros/fuerte/swig-wx is broken (I don't know ruby, so I can't debug it): swig-wx.rb:4: syntax error, unexpected '-', expecting '<' or ' ' or ';'

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2012-05-09 05:12:11 -0500 )edit
0

answered 2012-10-15 17:55:43 -0500

cchart gravatar image

I got the same error when installing fuerte from source on ubuntu quantal. The swig package (not swig2.0) was needed to fix this error and get me moving again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-05-08 16:59:49 -0500

Seen: 938 times

Last updated: Oct 15 '12