Ask Your Question
0

Problem with ee_cart_imped Controller for PR2 Arms [closed]

asked 2012-07-02 04:12:42 -0500

Mayank gravatar image

updated 2014-11-22 17:05:33 -0500

ngrennan gravatar image

Hi All,

I'm trying to move the PR2 arms through some predefined points. I have a launch file that first moves them using the default Joint Trajectory Controller on the PR2, and then the ee_cart_imped controller kicks in, and moves the arms through some cartesian coordinates.

My problem is that if initially the Joint Trajectory Controller has run, then the ee_cart_imped controller runs, but if the launch file just runs the ee_cart_controller, I get the following

[ INFO] [1341238106.346256027]: Waiting for the ee_cart_imped_action server

And it does not move the arm at all. Any ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-12-29 13:49:30

Comments

1

There are quite a few launch files in ee_cart_imped stack. Which one are you using? Maybe you want to post your launch file out so that we can see more details.

Nan Jiang gravatar image Nan Jiang  ( 2012-07-02 04:51:54 -0500 )edit

Thanks for your comment. I just figured out what was causing the problem.

Mayank gravatar image Mayank  ( 2012-07-02 05:03:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-18 08:47:23 -0500

shuai gravatar image

Hi, I have the same problem. Could you please post what is the cause to this problem? Thank you!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-02 04:12:42 -0500

Seen: 92 times

Last updated: Oct 18 '12