ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

RVIZ will not execute

asked 2012-06-03 10:29:52 -0500

rzv0004 gravatar image

I am trying to run a LiDar taken from the Neato XV-11 vacuum cleaner on ROS nad amd using RVIZ to visualize the data coming from the sensor. However, I ran into the problem that RVIZ was not receiving and MAP data to display. I consulted the site and As per the video tutorial under map, I found that I did not have any topics being displayed. I tried to enter the topic manually but not RVIZ will not initialize and I am receiving the following error.

[ERROR] [1338754771.604753719]: Caught exception while loading: Character [ ] at element [3] is not valid in Graph Resource Name [map (nav_msgs/OccupancyGrid)]. Valid characters are a-z, A-Z, 0-9, / and _.

Kindly suggest what when wrong and what can be done regarding the same.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-06-04 00:04:45 -0500

felix k gravatar image

Seems to me you placed a space in map (nav_msgs/OccupancyGrid) which is not valid.

Remove that space in ~/.rviz/display_config or ~/.rviz/config and start rviz.


edit flag offensive delete link more

answered 2012-06-04 18:37:18 -0500

rzv0004 gravatar image

Thanx, but where do I change it? It occured when i tried to manually change the topics in RVIZ, now even the RVIZ windo won't open. I tired looking in the config file in my rviz folder but could not find where the change was made by RVIZ. Kindly help.

edit flag offensive delete link more


Open both mentioned files and search for your buggy string "map (nav_msgs/OccupancyGrid)" or parts of it. And use comments on answers :)

felix k gravatar image felix k  ( 2012-06-06 01:15:59 -0500 )edit

Thanx. But I cannot open the file. I don't know where it is and I am having a hard time finding it. I tried to open the file through the cmd window but it keeps telling me a bunch of errors. I tried the open, edit and even the start command. None of them open the file that I want. Any suggestion?

rzv0004 gravatar image rzv0004  ( 2012-06-12 15:29:34 -0500 )edit

Umm.. the tilde ~ in linux paths is used to represent the users home directory. type cd ~/.rviz and then ls -- Guess #2: the directory for the new rviz in fuerte is ~/.rviz_qt

felix k gravatar image felix k  ( 2012-06-12 23:35:55 -0500 )edit

Im sorry, I should have mentioned this earlier. I am working on the electric version of the ros and am currently working on ubantu.

rzv0004 gravatar image rzv0004  ( 2012-06-27 13:50:48 -0500 )edit

I found a file named GetMap.lisp

but on top of the life the first line says auto generated and do not edit!

rzv0004 gravatar image rzv0004  ( 2012-06-27 14:24:44 -0500 )edit

Question Tools


Asked: 2012-06-03 10:29:52 -0500

Seen: 720 times

Last updated: Jun 04 '12