ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS melodic installation unmet dependencies problem

asked 2020-04-17 16:11:54 -0500

pmuthu2s gravatar image

updated 2020-05-16 17:01:03 -0500

Orhan gravatar image

Hey Guys,

I have tried all the possible solutions posted on ROS and other ubuntu forums. And yet I am unable to solve the error for the held broken packages.

sudo apt install ros-melodic-desktop-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ros-melodic-desktop-full : Depends: ros-melodic-desktop but it is not going to be installed
Depends: ros-melodic-perception but it is not going to be installed
Depends: ros-melodic-simulators but it is not going to be installed
Depends: ros-melodic-urdf-sim-tutorial but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The list of things tried: 1. Used Synaptic pacakge manger to remove ros-melodic 2. Followed this answer

Any suggestions?

edit retag flag offensive close merge delete


Hi @pmuthu2s,

This line E: Unable to correct problems, you have held broken packages. may be self explanatory. I think you have broken packages in your system and apt is unable to solve that. You may want to check your system packages and solve this broken ones before installing any other package. On the other hand if you can affort it, there is the possibility of reinstalling the OS.

Weasfas gravatar image Weasfas  ( 2020-04-18 05:40:00 -0500 )edit

Hello! I have just met this problem and been obstructed. I have tried many solutions but they don't work. may I ask for your solution ? i really appreciate!

WuShuangJJ gravatar image WuShuangJJ  ( 2020-08-27 03:44:22 -0500 )edit

@WuShuangJJ This is not a forum, it is a Q&A site. As such, please don't post answers that aren't actually answers. I've re-posted your answer as a question comment. Please see the support guidelines for more:

Good luck getting your issue resolved!

jarvisschultz gravatar image jarvisschultz  ( 2020-08-27 13:43:36 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2021-05-07 18:28:30 -0500

Provide a possibility 1. Provide a possibility: check the software with the updated server and choose the right 2. Open all software updates and update them. After the update is complete it will reboot and try to install ROS again

edit flag offensive delete link more

answered 2020-05-16 16:48:36 -0500

Orhan gravatar image

updated 2020-05-16 17:09:40 -0500

As strange as it sounds, this happened to me while I try to install ROS over teamviewer on a live USB. Yes, teamviewer.

From the start menu, find the software / updates section. Open this tab: image description Select all first 4 checkboxes.* Then click on [close] an then [close].

Go to terminal and run

sudo apt update && sudo apt install ros-melodic-desktop full
  • All of those four might not be necessary but click anyway.
edit flag offensive delete link more


Hey! Thanks!

I tried this before, but did not work! I will update the answer with the methodology that worked for me!

pmuthu2s gravatar image pmuthu2s  ( 2020-05-19 03:44:55 -0500 )edit

Have you solved this problem?

Audric Saragih gravatar image Audric Saragih  ( 2020-11-24 06:36:16 -0500 )edit

I remembered solving it somehow using sudo aptitude

Give it a check on the documentation !

pmuthu2s gravatar image pmuthu2s  ( 2020-11-24 08:48:06 -0500 )edit

Question Tools



Asked: 2020-04-17 16:11:54 -0500

Seen: 2,593 times

Last updated: May 16 '20