Global planner / global map does not inflate static obstacles at all.

asked 2019-12-04 11:32:49 -0600

Arul Selvam gravatar image

I am using "global_planner/GlobalPlanner" to compute global plans on a static map I publish from a png height map using map_server. My ros version in melodic.

My global planner config file looks like:

planners:
      - name: 'global_planner'
type: 'global_planner/GlobalPlanner'
planner_patience: 10.0

global_planner:
     allow_unknown: false
     default_tolerance: 0.0
     visualize_potential: true
     use_dijkstra: true
     use_quadratic: true
     use_grid_path: false
    old_navfn_behaviour: false
    lethal_cost: 253
    neutral_cost: 66
    cost_factor: 0.55

My global planner config file looks like:

global_costmap:
    global_frame: map
    robot_base_frame: base_link
    update_frequency: 10.0
    publish_frequency: 2.0
    static_map: true
    rolling_window: false
    width: 65.0
    height: 65.0
    resolution: 0.15

plugins:
  - name: static_layer
    type: costmap_2d::StaticLayer
  - name: inflator
    type: costmap_2d::InflationLayer

static_layer:
    map_topic: "map"
    subscribe_to_updates: false

inflator:
    inflation_radius: 1
    lethal_cost_threshold: 200

But the path generated does not respect inflation parameter specification. The global path always gets too close to the static obstacles. I couldn't upload an image of the generated plan due to lack of karma points. Hope someone can help me understand how to configure global planner and global cost map to inflate the static obstacles.

edit retag flag offensive close merge delete