ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS/ MoveIt! ERROR: Unable to identify any set of controllers that can actuate the specified joints

asked 2019-12-02 10:55:09 -0500

nmpm gravatar image

Hello, I've been trying to follow this tutorial to integrate quadcopters into MoveIt!

I need help trying to execute paths. I think I've done everything right till where I do the launch part. When I launch, the RVIZ pops up and the quadcopter appears, then I press 'plan' on the rviz and I can see a shadow moving from where my quadcopter is to where I want it to be (my goal). The problem is when I press 'execute', to actually go to the goal, I have the following errors, "[ERROR] Unable to identify any set of controllers that can actuate the specified joints: [ virtual_joint ]" and "[ERROR]:Known controllers and their joints:" In which appears none, or it doesn't have any known controllers. And then I get the following [INFO]: ABORTED: Solution found but controller failed during execution. I think this happens because when rviz is loading I get this:

[ERROR]: Exception while loading controller manager 'moveit_simple_controller_manager/MoveItSimpleControllerManager': Failed to load library /(...)/devel/lib/ Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = /(...)/devel/lib/ undefined symbol: _ZTVN32moveit_simple_controller_manager37FollowJointTrajectoryControllerHandleE)

I've tried searching online for this error, but I don't seem to find a solution. I think both names are consistent and I've tried sudo apt-get dist-upgrade and everything is up to date. Can someone help me fix this? Thanks in advance.

edit retag flag offensive close merge delete


I am having the same problem now. I am wondering if you found a solution to that or not. I tried the command c++filt _ZTVN32moveit_simple_controller_manager37FollowJointTrajectoryControllerHandleE to figure out where the problem was and I got vtable for moveit_simple_controller_manager::FollowJointTrajectoryControllerHandle. I thought that it may have something to do with the virtual functions declared the interface not being fully defined but all the fully virtual functions in moveit_controller_manager::MoveItControllerManager were implemented in the derive class. Here is the link to the file if anyone would like to take a look.

MakinoharaShouko gravatar image MakinoharaShouko  ( 2020-12-16 21:42:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2020-02-29 12:29:50 -0500

fvd gravatar image

I haven't seen this error, but it looks like a problem with your MoveIt installation or your controller/motor setup. The plan execution fails because MoveIt cannot talk to the controllers.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2019-12-02 10:55:09 -0500

Seen: 669 times

Last updated: Feb 29 '20