Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ROS/ MoveIt! ERROR: Unable to identify any set of controllers that can actuate the specified joints

Hello, I've been trying to follow this tutorial to integrate quadcopters into MoveIt!

I need help trying to execute paths. I think I've done everything right till where I do the launch part. When I launch, the RVIZ pops up and the quadcopter appears, then I press 'plan' on the rviz and I can see a shadow moving from where my quadcopter is to where I want it to be (my goal). The problem is when I press 'execute', to actually go to the goal, I have the following errors, "[ERROR] Unable to identify any set of controllers that can actuate the specified joints: [ virtual_joint ]" and "[ERROR]:Known controllers and their joints:" In which appears none, or it doesn't have any known controllers. And then I get the following [INFO]: ABORTED: Solution found but controller failed during execution. I think this happens because when rviz is loading I get this:

[ERROR]: Exception while loading controller manager 'moveit_simple_controller_manager/MoveItSimpleControllerManager': Failed to load library /(...)/devel/lib/ Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = /(...)/devel/lib/ undefined symbol: _ZTVN32moveit_simple_controller_manager37FollowJointTrajectoryControllerHandleE)

I've tried searching online for this error, but I don't seem to find a solution. I think both names are consistent and I've tried sudo apt-get dist-upgrade and everything is up to date. Can someone help me fix this? Thanks in advance.