Ask Your Question
1

catkin-pkg distribution was not found

asked 2018-07-04 03:53:47 -0500

kluessi gravatar image

Hi ROS-Community,

I am using ubuntu 16.04 with ROS Kinetic build from source. Today I tried to recompile my workspace, but now I get some errors using catkin_find_pkg, which does not allow me to compile any package at all.

If I try to compile my workspace:

CMake Error at CMakeLists.txt:20 (message):
Search for 'catkin' in workspace failed (catkin_find_pkg catkin
/home/hkluessendorff/ros/2-additional/src): Traceback (most recent call
last):

File "/usr/local/bin/catkin_find_pkg", line 5, in <module>
  from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2927, in <module>
  @_call_aside
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2913, in _call_aside
  f(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set
  working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 637, in _build_master
  return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 650, in _build_from_requirements
  dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 829, in resolve
  raise DistributionNotFound(req, requirers)

pkg_resources.DistributionNotFound: The 'catkin-pkg==0.4.3' distribution
was not found and is required by the application

I get the same error when I just invoke catkin_find_pkg

Traceback (most recent call last):
File "/usr/local/bin/catkin_find_pkg", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2927, in <module>
@_call_aside
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2913, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 637, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 650, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 829, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'catkin-pkg==0.4.3' distribution was not found and is required by the application

I looked inside python-catkin-pkg which I installed via apt-get

python-catkin-pkg is already the newest version (0.4.6-100).

It seems to me that somehow I need catkin-pkg version 0.4.3, but installed 0.4.6 via an apt-get upgrade.

Anybody of you has an idea how to solve this error?

Thanks in advance for your advice

Best regards,

edit retag flag offensive close merge delete

Comments

Can you check the version number of python-catkin-pkg-modules and update it in case it is lower than the one from python-catkin-pkg.

Dirk Thomas gravatar imageDirk Thomas ( 2018-07-05 08:56:18 -0500 )edit

I am having the same issue. How to check the version of the python-catkin-pkg-modules and how to install lower version of it, if I found that it is an issue?

LAB1824 gravatar imageLAB1824 ( 2018-09-24 22:12:09 -0500 )edit

@kluessi did you come up with any other solution?

LAB1824 gravatar imageLAB1824 ( 2018-09-24 22:12:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
-1

answered 2019-04-10 03:24:36 -0500

NadiaHammoudeh gravatar image

If the catkin-pkg version is right, easy_install should solve the problem:

easy_install --upgrade catkin-pkg

edit flag offensive delete link more

Comments

1

Installing Python packages which are available as Debian packages on Ubuntu is highly discouraged since it will overlay future updates.

Dirk Thomas gravatar imageDirk Thomas ( 2019-04-10 13:08:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-04 03:53:47 -0500

Seen: 785 times

Last updated: Apr 10