ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

gazebo is crashing:Segmentation fault

asked 2018-01-31 03:53:08 -0500

az gravatar image

updated 2018-01-31 06:44:43 -0500

gvdhoorn gravatar image

Hi, i have been trying to run gazebo7.0.0. with turtlebot3 burger simulation using ubuntu 16.04 and ros kinetic.When i do roslaunch it is throwing this error:


process[gazebo-1]: started with pid [9109]

process[gazebo_gui-2]: started with pid [9114]

process[spawn_urdf-3]: started with pid [9119]

[ INFO] [1517391849.942038025]: Finished loading Gazebo ROS API Plugin.

[ INFO] [1517391849.944605688]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Segmentation fault (core dumped)

[gazebo-1] process has died 
[pid 9109, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/az/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/models/ __name:=gazebo __log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

log file: /home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

I have read on few locations that it can be due to poor graphics card.Is there any way to confirm it or any other thing i should check? Also when i just write gazebo in terminal it doesnt throw any error but GUI doesnt come up either.i tried gazebo --verbose which looks fine with following output:

Gazebo multi-robot simulator, version 7.0.0
Copyright (C) 2012-2016 Open Source Robotics Foundation.
Released under the Apache 2 License.

[Msg] Waiting for master.
Gazebo multi-robot simulator, version 7.0.0
Copyright (C) 2012-2016 Open Source Robotics Foundation.
Released under the Apache 2 License.

[Msg] Waiting for master.
[Msg] Connected to gazebo master @
[Msg] Publicized address:


edit retag flag offensive close merge delete


roslaunch works fine. Gazebo is crashing.

Please update your question title to reflect that.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-31 04:08:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-01-31 09:03:42 -0500

updated 2018-01-31 09:03:56 -0500

I'm assuming you're using a non-NIVIDIA graphics chipset.

Gazebo seems to work best with NVIDIA graphics cards. That is because it was tested against NVIDIA graphics cards in development.

Some thing you can try:
1) Ctrl-C roslaunch window, then roslaunch again (repeat) (this would work most of the time for me using an AMD graphics card).

2) Install updates

$ sudo apt-get dist-upgrade
$ sudo apt-get update
$ sudo apt-get upgrade

3) Use the proprietary driver for your graphics card (if available) image description

4) Get a NVIDIA graphics card - an older-ish one is fine. You're only using it to render the scene.

Additional Info:
Gazebo Answers is generally the best resource for Gazebo-related questions.

edit flag offensive delete link more



Thankyou for your answer,but it doesnt work.This is my system specifications. VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller]) Some of my friends claimed that it worked for them without a dedicated graphics card.

az gravatar image az  ( 2018-01-31 11:56:07 -0500 )edit

Yeah, Gazebo is really flaky with non-NVIDIA graphics cards. I'd say switching to a NVIDIA is your best bet. Alternatively you could try a AMD card if you have one - I used an AMD card for a few months and it was OK (other than having to roslaunch/ctrl-c things 2-3 times before they worked).

josephcoombe gravatar image josephcoombe  ( 2018-01-31 12:02:46 -0500 )edit

Thanks josephcoombe. Trying to run 2-3 times worked!

spacewandererer gravatar image spacewandererer  ( 2018-04-26 14:11:29 -0500 )edit

hello, I tried to run 5 times, but it doesn't work! Has it any other solutions??

lyz gravatar image lyz  ( 2019-02-17 20:59:11 -0500 )edit

What happens when you get this error AND you already have an NVIDA card though...

liamr0y gravatar image liamr0y  ( 2022-03-11 23:56:40 -0500 )edit

Question Tools


Asked: 2018-01-31 03:53:08 -0500

Seen: 9,008 times

Last updated: Feb 17 '19