Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ROSLaunch doesnt work:Segmentation fault

Hi, i have been trying to run gazebo7.0.0. with turtlebot3 burger simulation using ubuntu 16.04 and ros kinetic.When i do roslaunch it is throwing this error:

ROS_MASTER_URI=http://localhost:11311

process[gazebo-1]: started with pid [9109]

process[gazebo_gui-2]: started with pid [9114]

process[spawn_urdf-3]: started with pid [9119]

Segmentation fault (core dumped)

[gazebo-1] process has died [pid 9109, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/az/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/models/empty.world __name:=gazebo __log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

log file: /home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

I have read on few locations that it can be due to poor graphics card.Is there any way to confirm it or any other thing i should check?Thanks

click to hide/show revision 2
None

ROSLaunch doesnt work:Segmentation fault

Hi, i have been trying to run gazebo7.0.0. with turtlebot3 burger simulation using ubuntu 16.04 and ros kinetic.When i do roslaunch it is throwing this error:

ROS_MASTER_URI=http://localhost:11311

ROS_MASTER_URI=http://localhost:11311
  

process[gazebo-1]: started with pid [9109]

[9109]

process[gazebo_gui-2]: started with pid [9114]

[9114]

process[spawn_urdf-3]: started with pid [9119]

[9119] [ INFO] [1517391849.942038025]: Finished loading Gazebo ROS API Plugin.

[ INFO] [1517391849.944605688]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting... Segmentation fault (core dumped)

dumped)

[gazebo-1] process has died [pid 9109, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/az/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/models/empty.world __name:=gazebo __log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

__log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

log file: /home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

I have read on few locations that it can be due to poor graphics card.Is there any way to confirm it or any other thing i should check?Thanks

ROSLaunch doesnt work:Segmentation fault

Hi, i have been trying to run gazebo7.0.0. with turtlebot3 burger simulation using ubuntu 16.04 and ros kinetic.When i do roslaunch it is throwing this error:

ROS_MASTER_URI=http://localhost:11311

process[gazebo-1]: started with pid [9109]

process[gazebo_gui-2]: started with pid [9114]

process[spawn_urdf-3]: started with pid [9119]

[ INFO] [1517391849.942038025]: Finished loading Gazebo ROS API Plugin.

[ INFO] [1517391849.944605688]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Segmentation fault (core dumped)

[gazebo-1] process has died 
[pid 9109, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/az/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/models/empty.world __name:=gazebo __log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

log file: /home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

I have read on few locations that it can be due to poor graphics card.Is there any way to confirm it or any other thing i should check?Thankscheck?Also when i just write gazebo in terminal it doesnt throw any error but GUI doesnt come up either.i tried gazebo --verbose which looks fine with following output: Gazebo multi-robot simulator, version 7.0.0 Copyright (C) 2012-2016 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Waiting for master. Gazebo multi-robot simulator, version 7.0.0 Copyright (C) 2012-2016 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.11.4

Thanks

ROSLaunch doesnt work:Segmentation gazebo is crashing:Segmentation fault

Hi, i have been trying to run gazebo7.0.0. with turtlebot3 burger simulation using ubuntu 16.04 and ros kinetic.When i do roslaunch it is throwing this error:

ROS_MASTER_URI=http://localhost:11311

process[gazebo-1]: started with pid [9109]

process[gazebo_gui-2]: started with pid [9114]

process[spawn_urdf-3]: started with pid [9119]

[ INFO] [1517391849.942038025]: Finished loading Gazebo ROS API Plugin.

[ INFO] [1517391849.944605688]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Segmentation fault (core dumped)

[gazebo-1] process has died 
[pid 9109, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/az/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/models/empty.world __name:=gazebo __log:=/home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1.log].

log file: /home/az/.ros/log/b5f081e4-05e5-11e8-b31b-001aa0c71fa4/gazebo-1*.log

I have read on few locations that it can be due to poor graphics card.Is there any way to confirm it or any other thing i should check?Also check? Also when i just write gazebo in terminal it doesnt throw any error but GUI doesnt come up either.i tried gazebo --verbose which looks fine with following output: output:

Gazebo multi-robot simulator, version 7.0.0
Copyright (C) 2012-2016 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

http://gazebosim.org [Msg] Waiting for master. Gazebo multi-robot simulator, version 7.0.0 Copyright (C) 2012-2016 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

http://gazebosim.org [Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.11.4

192.168.11.4

Thanks