ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Not enough ethercat slaves to create youbot manipulator

asked 2017-10-10 03:08:58 -0500

herroineedhelp gravatar image

Hi all, I have encountered an error when bringing up my youbot. It says " Not enough ethercat slaves to create a youbot manipulator" and hence, my arm is not working. Urgently help is needed thank you!

edit retag flag offensive close merge delete

Comments

Hi herroineedhelp, Can you send screenshots ? Which Ethercat software driver you are using and which ethercat motion controller you are using for manipulator?

TraiBo gravatar image TraiBo  ( 2018-01-30 00:52:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-17 14:45:32 -0500

updated 2018-10-17 14:46:30 -0500

We really need to know which driver are you using, a good driver for the youbot can be found here.

Then execute ifconfig on the physicall robot terminal to get the ethernet adapter names. The Ethernet adapter name needs to be configured in ethercat.cfg

When the names don't match you get the error you are describing.

Hope it helps... unfortunately we can't give any more specific directions if you don't inform us about which youbot driver are you using... for the record, the one from youbot store can be found here

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2017-10-10 03:08:58 -0500

Seen: 231 times

Last updated: Oct 17 '18