YouBot: Cannot read gripper values

asked 2015-12-08 13:58:35 -0500

AlejandroBordallo gravatar image

We have been performing many youBot manipulation experiments, and most of the experiments proceed well, but randomly during them we get:

[ WARN] [1449597292.790741537]: Receiving data failed
[ WARN] [1449597293.014359676]: Cannot read gripper values: Unable to get parameter: ActualPosition from the gripper
[ WARN] [1449597293.217931475]: Receiving data failed
[ERROR] [1449597293.320430594]: Lost EtherCAT connection
[ WARN] [1449597293.442503860]: Cannot read gripper values: Unable to get parameter: ActualPosition from the gripper
[ WARN] [1449597293.446424837]: No EtherCAT connection

This is followed by the youbot_driver stopping responding, and multiple identical warnings and erros repeatedly being printed. Has anyone encountered this issue before? It would seem that the gripper etherCAT communication just stops.

Our youBot is 12.04 Hydro, every ROS package is up to date. We actually have multiple youBots and we have tried with them too, but we get the same issue (So it is unlikely to be a hardware fault). We use youbot_driver, youbot_driver_ros_interface, youbot_manipulation, moveit and so on (i.e. The default pipeline for youBot arm control and manipulation).

We have tried using the following youbot_driver branch since it seemed to tackle the same issue: https://github.com/youbot/youbot_driv...

But it did not solve the problem for us. We have contacted KUKA support but they do not know what it could be.

Here is the code we use in order to control and use the youBot, in case you think the problem may be higher up. https://github.com/ipab-rad/youbot_pi...

Thank you for your responses, Alex

edit retag flag offensive close merge delete

Comments

Hi I have similar problem. I was dismounting gripper, after reconnection of the same gripper back to arm is program at start of youbot_driver write this problem Did you solved this problem? HOW?

Saimonko gravatar imageSaimonko ( 2018-04-10 07:18:48 -0500 )edit