Ask Your Question
0

arbotix_ros can not detect servos via arbotix-m controller

asked 2017-09-26 18:26:08 -0500

Abdu gravatar image

updated 2017-09-26 18:26:51 -0500

Hi all I am using ros indigo and ubuntu 14.04. I have Phantomx Pincher arm connected to the computer via FTDI USB cable.

I clone arbotix_ros and I did catkin_make properly.

BUT I can not detect my servos (dynamixel ax-12a) thru arbotix-m, I am getting the following output,

anyone can help me please ??

I even tried arbotix_gui I got the window but the servos don't move.

    imr@IMR-PC:~$ sudo chmod 777 /dev/ttyUSB0    
    [sudo] password for imr: 
     imr@IMR-PC:~$ arbotix_terminal
     ArbotiX Terminal --- Version 0.1
    Copyright 2011 Vanadium Labs LLC
        >>  ls
    .... .... .... .... .... .... .... .... .... 
    .... .... .... .... .... .... .... .... .... 
    >>  ls
    .... .... .... .... .... .... .... .... ....
    .... .... .... .... .... .... .... .... ....
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-03 13:58:25 -0500

Abdu gravatar image

I figured it out that I have to upload ros.ino to the arbotix-m board after making sure that the baud rate should be Serial.begin(115200);

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-26 18:26:08 -0500

Seen: 590 times

Last updated: Oct 03 '17