run my new planner on demo.launch of pr2 robot

asked 2017-06-15 11:22:06 -0600

Oh233 gravatar image

I added new planner and state space in ompl and I want to do a simulation on pr2 robot now. I compiled all codes out but when I ran the demo.launch file, after I set the initial and goal state and pushed planning button, I met the error. Here is the output:

[move_group-5] process has died [pid 30258, exit code -11, cmd /home/ruinianxu/ws_moveit/devel/lib/moveit_ros_move_group/move_group --debug __name:=move_group __log:=/home/ruinianxu/.ros/log/4d8e3574-51e5-11e7-ad3f-1c6f6540c1be/move_group-5.log]. log file: /home/ruinianxu/.ros/log/4d8e3574-51e5-11e7-ad3f-1c6f6540c1be/move_group-5*.log

I already tried to find this log file to see whether I can find code stopped at which line. But I found the root directory but there was no log file named move_group-5*.log. What I can confirm is this problem is caused by my state space since when I set my planner using default state space, it will not crash. Anybody has any idea about this?

edit retag flag offensive close merge delete