Ask Your Question
-1

LMS1XX on ROS Kinetic

asked 2017-05-12 08:54:43 -0600

mtROS gravatar image

updated 2017-05-15 06:38:10 -0600

Hy,

I am trying to get a connection in ROS Kinetic to my LMS111 Laserscanner with:

 rosrun lms1xx LMS1xx_node _host:=192.168.3.7

The result is a connection fail. I saw the other posts like http://answers.ros.org/question/20722... and http://answers.ros.org/question/66437... bbut there is never a full description to the solution... Does anyone have an idea what could be the problem or could provide a full solution path?

Thanks in advance,

Michael

edit retag flag offensive close merge delete

Comments

1

I think the problem is due to permission of the port. Try $ sudo chmod a+rx [port of the LMS] before launching the lms node. It should work. I have had no problems using LMS sensors on ROS kinetic so far.

AlexR gravatar imageAlexR ( 2017-05-14 23:00:58 -0600 )edit

i messed up the configuration, thanks for your answer, i added a solution path below.

mtROS gravatar imagemtROS ( 2017-05-15 02:43:12 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-15 02:39:00 -0600

mtROS gravatar image

updated 2017-05-15 02:45:15 -0600

In order to establish a connection of the Laserscanner SICK LMS111 to ROS Kinetic several steps have to be performed.

1.Supply the Sensor and connect it to the ethernet port a system running Windows. 2. Install SICK SOPAS Engineering tool and execute it. 3. Configure the Paramters in the SICK Software SOPAS. That means define a ethernet ip adress and adjust measuring parameters. 4.Install the sick toolbox wrapper:

$ sudo apt-get install ros-kinetic-lms1xx

  1. In Ubuntu under Settings configure the wired connection to be different than the IP of the laserscanner. The IP of the laserscanner can be obtained by

$ sudo ifconfig

  1. Make sure that the connection between ubuntu and the LMS is established in Ubuntu (You can see this in the Network Settings).

$ roscore

  1. In order to establish a connection to ROS use a new terminal and enter

$ rosrun lms1xx LMS1xx_node _ host:=[IP of the scanner obtained from sudo ifconfig]

has to be used.

9.When using rviz: the fixed frame in global options has to be set to laser and a LaserScan display has to be added with the topic /scan enabled.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-12 08:54:43 -0600

Seen: 1,244 times

Last updated: May 15 '17