Ask Your Question
0

ca_driver deploy catkin_make

asked 2016-12-11 10:27:09 -0500

ChriMo gravatar image

Hello community,

I try to deploy ca_driver from create_autonomy to multiple devices.

Problem: catkin_make install did not install ca_driver to install-dir.

Bug or feature ? Any suggestions ?

Thanks Cheers Chrimo

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-11 11:57:21 -0500

gvdhoorn gravatar image

Problem: catkin_make install did not install ca_driver to install-dir.

This is actually not a problem with catkin_make: the current CMakeLists.txt of ca_driver (here) simply does not contain any install(..) statements.

Running catkin_make install will therefore not install anything, as there are no instructions to do so.

I'd report this to the AutonomyLab people over at their issue tracker.

edit flag offensive delete link more

Comments

I've copied the binary manually to destination.

Thanks for the fast answer Cheers Chrimo

ChriMo gravatar image ChriMo  ( 2016-12-11 16:19:40 -0500 )edit

It would be really nice if you could report this to their issue tracker, as that would make this work for other users as well.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-12 02:02:58 -0500 )edit

Expect an update to create_autonomy tonight with install rules (with some other small changes I've been meaning to get to as well).

jacobperron gravatar image jacobperron  ( 2016-12-12 12:47:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-11 10:27:09 -0500

Seen: 87 times

Last updated: Dec 11 '16