ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Roomba 400 AMCL launch file error

asked 2018-04-04 07:12:52 -0600

Ezredes gravatar image

Hello! I'm using room 400 with the create_autonomy driver. I set up the navigation stack, AMCL and so on, as described in the following launch file. I created a map and used with the map server, also run gslam as the tutorial described.

  <master auto="start"/>

  <!-- Run the map server -->
  <!--  <node name="map_server" pkg="map_server" type="map_server" args="$(find piros_2dnav)/src/map.pgm"/> -->

  <!--- Run AMCL -->
  <include file="$(find amcl)/examples/amcl_omni.launch" />

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find piros_2dnav)/src/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find piros_2dnav)/src/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find piros_2dnav)/src/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find piros_2dnav)/src/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find piros_2dnav)/src/base_local_planner_params.yaml" command="load" />

I created the package, witch containst the launc file with the following command:

catkin_create_pkg piros_2dnav move_base

When I tried to run the launch file (whitch based on the tutorials and turtlebot docs) I received the following console error message:

core service [/rosout] found
process[amcl-1]: started with pid [22888]
process[move_base-2]: started with pid [22889]
[ INFO] [1522842405.749090573]: Using plugin "static_layer"
[ INFO] [1522842405.763204034]: Requesting the map...
[ INFO] [1522842405.985357466]: Resizing costmap to 4000 X 4000 at 0.050000 m/pix
[ INFO] [1522842406.122298682]: Received a 4000 X 4000 map at 0.050000 m/pix
[ INFO] [1522842406.131703346]: Using plugin "obstacle_layer"
[ INFO] [1522842406.151662398]:     Subscribed to Topics: laser_scan_sensor
[ INFO] [1522842406.224796288]: Using plugin "inflation_layer"
terminate called after throwing an instance of 'XmlRpc::XmlRpcException'
[move_base-2] process has died [pid 22889, exit code -6, cmd /opt/ros/kinetic/lib/move_base/move_base __name:=move_base __log:=/home/ezredes/.ros/log/6886f124-37ed-11e8-a09c-240a64281697/move_base-2.log].
log file: /home/ezredes/.ros/log/6886f124-37ed-11e8-a09c-240a64281697/move_base-2*.log

In the /home/ezredes/.ros/log/6886f124-37ed-11e8-a09c-240a64281697/ folder there aren't any log file with name move_base-2.log. What does this error actually means? Whats wrong with my launch file?

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-04-22 13:32:03 -0600

jacobperron gravatar image

I'm guessing that the XmlRpcException occurs when reading ROS params in move_base. Perhaps the bug is in one of your config files. Try looking for typos or formatting errors in the following files:

  • costmap_common_params.yaml
  • local_costmap_params.yaml
  • global_costmap_params.yaml
  • base_local_planner_params.yaml
edit flag offensive delete link more


Thank you! I ran into the same issue. And after I reconfig the footprint in costmap_common_params.yaml, I solve the problem.

Heho gravatar image Heho  ( 2021-03-20 03:13:01 -0600 )edit

Question Tools

1 follower


Asked: 2018-04-04 07:12:52 -0600

Seen: 318 times

Last updated: Apr 22 '18