Ask Your Question
0

problem to run kinova Mico2 robotic arm

asked 2016-11-20 18:55:11 -0500

Abbas gravatar image

Hi,

I follow this tutorial "https://github.com/Kinovarobotics/kinova-ros" to control kinova mico 2 robotic arm (4DOF, with 2 fingers gripper). When I run this roslaunch kinova_bringup kinova_robot.launch kinova_robotType:=m2n4a200 use_urdf:=true, I got this error:

... logging to /home/abbas/.ros/log/29b74d74-af7a-11e6-bcec-000c291b5b22/roslaunch-ubuntu-6431.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!

To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
No such file or directory: /home/abbas/catkin_ws/src/kinova-ros/kinova_description/urdf/m2n4a200_standalone.xacro
XacroException('No such file or directory: /home/abbas/catkin_ws/src/kinova-ros/kinova_description/urdf/m2n4a200_standalone.xacro',)
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/share/xacro/xacro.py '/home/abbas/catkin_ws/src/kinova-ros/kinova_description/urdf/m2n4a200_standalone.xacro'] returned with code [2]. 

Param xml is <param command="$(find xacro)/xacro.py '$(find kinova_description)/urdf/$(arg kinova_robotType)_standalone.xacro'" name="robot_description"/>
The traceback for the exception was written to the log file

I could not find any xacro script for mico2 robotic arm in urdf folder (in kinova_description). How can I solve this issue?

Thanks,

Abbas

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-02 00:39:10 -0500

DT gravatar image

You have 2 steps to figure out this problem :

First is to go to your Xacro files which are in your robot_description package and for each one of them type this command at the Terminal :

" rosrun xacro xacro [filename.xacro/filename.urdf.xacro] "

Then you can find out where is the problem comes from.

And the second step is to go to this site

" http://wiki.ros.org/xacro "

And read about the new changes to convert your file and resolve the problem.

Good luck

edit flag offensive delete link more

Comments

Hi DT,

Thank you for your answer. I communicated with the kinova company, First, they said I can use the urdf of mico1. Second they sent me edited kinova_comm.cpp in kinov_adriver/src and it works now.

Abbas gravatar image Abbas  ( 2016-12-02 08:36:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-20 18:55:11 -0500

Seen: 272 times

Last updated: Nov 20 '16