Ask Your Question
0

robot_localization publishing to tf incorrectly

asked 2016-08-10 17:18:57 -0600

ras_cal gravatar image

updated 2016-08-11 07:02:38 -0600

I have left the robot_localization odom_frame parameter with value "odom" and base_link_frame to "base_link" defaults. The tf tree, while running robot_localization and the robot driver ca_driver with publish_tf set to "false". Looks like this (apparently I can't upload a file with less than 5 points): odom floating. base_footprint ---> base_link (broadcaster /ekf_localization) base_link --> right_wheel link (broadcaster /robot_state_publisher) base_link --> left_wheel link (broadcaster /robot_state_publisher) ....

why is ekf_localization broadcasting base_footprint --> base_link ? and leaving odom floating? (not connected to anything) I can't even find base_footprint anywhere in the robot_localization parameter list. It is part of the robot description. Any help clarifying this would be appreciated.

Edit

Adding image of original tf tree image description

edit retag flag offensive close merge delete

Comments

I've bumped your karma; you should be able to post images now.

ahendrix gravatar imageahendrix ( 2016-08-10 18:31:03 -0600 )edit

Thank you. I've posted image.

ras_cal gravatar imageras_cal ( 2016-08-11 07:03:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-11 12:13:00 -0600

ras_cal gravatar image

by changing the base_link_frame parameter value from base_link to base_footprint I was able to connect the odom frame to base_footprint. I can now run the robot and visualize the ekf_localization output in RViz. Interestingly, the base_footprint to base_link transform is now broadcast by /robot_state_publisher

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-10 17:18:57 -0600

Seen: 299 times

Last updated: Aug 11 '16