I run pid controller on uwsim based on the localization system I wrote, the vehicle move very slowly [closed]

asked 2016-02-25 08:39:58 -0500

ZYS gravatar image

I run pid controller on uwsim based on the localization system I wrote which means the current position is provided by my localization system instead of the topic such as "/g500/pose" and "/uwsim/girona_500/odom". No matter how big the kp is, the velocity of the auv is almost the same. I don't know why.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Javier Perez
close date 2016-03-01 04:34:35.376373

Comments

1

I think I need more information in this question. I guess you are already using the underwater_vehicle_dynamics. Your controller is publishing to the thrusters topic?. If you are running the default launch, have you disabled the keyboard controller?. Also note g500 thrusters have a 1.0 max effort.

Javier Perez gravatar imageJavier Perez ( 2016-02-25 09:34:20 -0500 )edit

Thank you so much. After I disabled the keyboard controller, the speed is much more fast. But why?

ZYS gravatar imageZYS ( 2016-02-25 09:58:47 -0500 )edit

keyboard controller sends periodically the readings from the keyboard. If it reads nothing it sends 0 to the thrusters. So some simulation steps were "wasted" with 0.0 thruster speed instead of the speed you were sending.

Javier Perez gravatar imageJavier Perez ( 2016-02-25 10:18:14 -0500 )edit

Thank you! Your suggestion is really helpful!

ZYS gravatar imageZYS ( 2016-02-25 13:38:37 -0500 )edit