Ask Your Question
1

Robot_state_publisher dies on ARM-based Turtlebot

asked 2015-06-04 16:17:54 -0500

nckswt gravatar image

updated 2015-06-04 17:40:36 -0500

Whenever I run roslanch turtlebot_bringup minimal.launch I get the following error:

[robot_state_publisher-2] process has died [pid 1597, exit code -11, cmd /opt/ros/indigo/lib/robot_state_publisher/robot_state_publisher __name:=robot_state_publisher __log:=/home/odroid/.ros/log/02472614-0afe-11e5-884e-c22209f25fe8/robot_state_publisher-2.log].
log file: /home/odroid/.ros/log/02472614-0afe-11e5-884e-c22209f25fe8/robot_state_publisher-2*.log

The log file is empty, however. If I run rosrun robot_state_publisher robot_state_publisher I get a segmentation fault. When I compile and run robot_state_publisher using gdb, here's the seg fault info:

Starting program: /home/odroid/catkin_ws/devel/lib/robot_state_publisher/robot_state_publisher 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0xb660bc74 in ?? () from /lib/arm-linux-gnueabihf/libpcre.so.3

I'd imagine this is because I'm running everything on an Odroid U3 with Ubuntu 14.04 and ROS Indigo Ubuntu ARM. Anyone else have this issue?

edit retag flag offensive close merge delete

Comments

Hi. Im using Jetson TK1 and facing the same problem. Did you get out of it? please help me.

vishu2287 gravatar imagevishu2287 ( 2015-08-20 00:58:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2015-06-05 01:59:49 -0500

gvdhoorn gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-04 16:17:54 -0500

Seen: 769 times

Last updated: Jun 05 '15