Ask Your Question
0

urdf in rviz is too deep

asked 2015-04-30 04:25:41 -0500

felixwatzlawik gravatar image

Hi, I setup my robot system and its working good.

I am using hector mapping with urdf and a laserscanner and I am getting the following result: image description I dont know why exactly the robot is kind of swimming in the world, here is my tf tree:

image description

Another Question is now, how can I make the Robot move autonomously and how can I integrate a path planner? What is a common used module to make the robot move and avoid obstacles and crashes?

thanks in advance, felix

edit retag flag offensive close merge delete

Comments

For your second question, you'll want to check out the navigation stack. It has packages that include local and global path planning, and it is the most common way to get started with autonomous navigation in ROS.

jarvisschultz gravatar imagejarvisschultz ( 2015-04-30 08:35:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-30 10:56:47 -0500

gvdhoorn gravatar image

I dont know why exactly the robot is kind of swimming in the world [..]

A likely reason is because you have placed the origin of your urdf (typically called base_link) in the centre of the yellow (?) cube. The origin of a cube in URDF is not at one of its corners, but in its centre.

If you place you base_link (or whatever the first link of your robot is called) at ground level, your robot should no longer be 'swimming'.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-30 04:25:41 -0500

Seen: 262 times

Last updated: Apr 30 '15