Ask Your Question

Loading 3D model moveit issue

asked 2015-03-01 08:16:47 -0500

ROSkinect gravatar image

updated 2015-03-02 08:15:29 -0500

Hi there !

I did an URDF for a robot in Computer-1 and it worked fine:

image description

but when I moved to Computer-2 I can't load my URDF in it and this is what i get:

image description

and this is what I get in the shell using my own package:

image description Click me to extend

and this is what I get in the shell using staubli_rx160_support package:

image description

Click me to extend

More info:

Ubuntu 12.04 LTS 32 bit, ROS Hydro

edit retag flag offensive close merge delete



Please add more information: Linux distribution, version of distribution, ROS version, installed from source or binaries?

gvdhoorn gravatar image gvdhoorn  ( 2015-03-01 13:28:29 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2015-03-02 08:12:50 -0500

ROSkinect gravatar image

updated 2015-03-02 08:13:39 -0500

The problem is solved:

in Moveit official website is written:

Note for Ubuntu 13.4 32 bit users: There is a bug with GCC 4.7 on Ubuntu 13.4 32bit with Eigen 3.1.2. It’s not likely to be fixed, so upgrade/downgrade your system to 13.4 64 bit resp. 12.4.

So don't use 32 bit distributions.

edit flag offensive delete link more


Ubuntu 12.04 LTS 32 bit, ROS Hydro

the note you copied should apply only to ubuntu 13.04 users, which you seem not to be. I'm running a 12.04 32bit installation with MoveIt (from source and installed using apt-get) and don't experience any issues.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-02 08:21:50 -0500 )edit

I though that there is an issue with 32 bit either for Ubuntu 13 or 12, I don't know why you don't have the same problem. Now I'm using Ubuntu 12.04 64 bit and it woks fine

ROSkinect gravatar image ROSkinect  ( 2015-03-02 09:53:35 -0500 )edit

answered 2015-03-01 10:03:34 -0500

gvdhoorn gravatar image

updated 2015-03-01 13:27:55 -0500

[ WARN] [1425218598.009362723]: Assimp reports no scene in file:///home/jros/Downloads/staubli-hydro-devel/staubli_rx160_support/meshes/rx160/collision/base_link.stl

The quoted warning should give you enough information: the assimp library (used for loading mesh resources in many parts of ROS), cannot deal with the stl files that you (through the MoveIt Setup Assistant) are requesting it to load.

This could be a known issue with assimp. See planning_component_visualizer bug and ros-pkg/ticket/4740 (on the old ROS trac). In short: replace string solid at the start of your stl with something else.

Why this didn't happen on 'Computer 1', I cannot say.

PS: It would seem that these are actually not the meshes that are distributed in the staubli_rx160_support package from ROS-Industrial, as those do not suffer from the issue described. I'm also pretty sure that the meshes shown in your first screenshot are in fact not from an RX160. I would advise you to create your own package, which reflects the actual model you have. This would also avoid potential name-clashes with the 'real' RX160 support pkg.


and this is what I get in the shell using staubli_rx160_support package:

How did you download those files? Could you check the first few bytes of base_link.stl for instance?

Edit2: ok, then this could be an OpenGL / video card driver issue. Make sure you have the correct -- and up-to-date -- drivers for your video card installed.

At the point where the Setup Assistant is loading the urdf, it starts to make proper use of your OpenGL subsystem. If anything is not ok there, it might lead to crashes such as your seeing. This is especially true if you are running Ubuntu/ROS in a VM.

In any case, make sure you have the correct (and up-to-date) drivers installed (check output of glxinfo, look at OpenGL vendor/renderer/version strings).

edit flag offensive delete link more


In fact I have done my own package for TX60 and it works fine in Computer-1 PS: in both computers installed Ubuntu 12.04 32-bit It seem that Moveit is not well installed because I tested two packages (my own and staubli_rx160_support) that I know they work I just edit my question to the new erro

ROSkinect gravatar image ROSkinect  ( 2015-03-01 10:45:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-03-01 08:16:47 -0500

Seen: 677 times

Last updated: Mar 02 '15