ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Gazebo, KUKA iiwa lbr

asked 2018-11-30 03:53:47 -0500

Getchbold NT gravatar image

updated 2018-11-30 05:55:28 -0500

Hi everyone,

I am newbie with Gazebo, ROS and Moveit. I would like to run the simulation of KUKA iiwa LBR 14 on Gazebo.

When i typed commands on Terminals:

roslaunch iiwa_description iiwa14_upload.launch

roslaunch iiwa_control iiwa_control.launch

roslaunch iiwa_gazebo iiwa_gazebo.launch

roslaunch iiwa_moveit demo.launch

Everything seems fine, and no errors happened. However, after that ( maybe after timeout ), I received warnings:

  • In the Terminal where i run roslaunch iiwa_control iiwa_control.launch: [ WARN] [1543570609.227085785]: Received JointState is 1543570595.164948 seconds old

  • In the Termianl where i run roslaunch iiwa_gazebo iiwa_gazebo.launch: [ WARN] [1543570608.601531290, 13.476000000]: Shutdown request received. [ WARN] [1543570608.601586976, 13.476000000]: Reason given for shutdown: [new node registered with same name]

  • In the Terminal where i run roslaunch iiwa_moveit demo.launch: [ WARN] [1543570614.032411545, 18.783000000]: Deprecation warning: Trajectory execution service is deprecated (was replaced by an action). Replace 'MoveGroupExecuteService' with 'MoveGroupExecuteTrajectoryAction' in move_group.launch

I think the reason I could not control KUKA iiwa LBR 14 in Gazebo is that there is no link between Gazebo and Moveit.

Can you please give me some comments? Thanks in advances,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-30 13:41:30 -0500

ryan.delgizzi gravatar image

This looks like a difference between real time and simulation time. Simulation time starts at 0, so the difference between real time and simulation time is approximately real time, which is what you are seeing.

ROS uses simulation time, published on /clock, when the param use_sim_time is true. use_sim_time is set when launching gazebo. My hunch is that you need to launch the gazebo file first, then all subsequent files. See the ROS Time Docs for more information.

As for the message in the gazebo terminal regarding shutdown... I suspect that some node is being launched in both files. Look through the launch files, and I suspect there is one that you do not need to launch twice.

edit flag offensive delete link more

Comments

thank you so much for your answer

Getchbold NT gravatar imageGetchbold NT ( 2019-04-24 04:00:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-11-30 03:53:47 -0500

Seen: 119 times

Last updated: Nov 30 '18