Ask Your Question
2

Raspberry Pi 2B and Indigo

asked 2015-02-07 18:20:13 -0500

TommyP gravatar image

Are there any working instructions for installing Indigo on the new Raspberry Pi 2B (Armv7) and the latest Raspbian image? I tried following the instructions for Raspbian in the wiki but there were problems.

First there was a conflict with python-setuptools. If the package was taken from ros repo it did not work. It tried to use python files in /usr/local... but these files were not there.

The the instructions say to install "wget http://archive.raspbian.org/raspbian/... . But will this deb work for the new board?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-02-08 02:48:50 -0500

updated 2015-02-08 02:49:47 -0500

I got ros base install to build following the instructions here

http://wiki.ros.org/ROSberryPi/Instal...

the python tools didn't work first time, sorry cant remember what I did that fixed it - I think installing python-dev and just doing it over again fixed it, but trying to build for turtlebot kobuki ftdi failed with

==> make -j4 -l4 in '/home/pi/ros_catkin_ws/build_isolated/kobuki_ftdi' Scanning dependencies of target ftdi_kobuki Scanning dependencies of target flasher Scanning dependencies of target find_devices Scanning dependencies of target ftdi_read_eeprom [ 20%] [ 20%] [ 30%] [ 40%] Building CXX object src/CMakeFiles/flasher.dir/flasher.cpp.o Building CXX object src/CMakeFiles/find_devices.dir/find_devices.cpp.o Building CXX object src/CMakeFiles/ftdi_kobuki.dir/ftdi_kobuki.cpp.o Building CXX object src/CMakeFiles/ftdi_read_eeprom.dir/ftdi_read_eeprom.cpp.o /home/pi/ros_catkin_ws/src/kobuki_core/kobuki_ftdi/src/ftdi_kobuki.cpp:60:18: fatal error: ftdi.h: No such file or directory compilation terminated. /home/pi/ros_catkin_ws/src/kobuki_core/kobuki_ftdi/src/ftdi_read_eeprom.cpp:45:18: fatal error: ftdi.h: No such file or directory compilation terminated. src/CMakeFiles/ftdi_kobuki.dir/build.make:54: recipe for target 'src/CMakeFiles/ftdi_kobuki.dir/ftdi_kobuki.cpp.o' failed make[2]: * [src/CMakeFiles/ftdi_kobuki.dir/ftdi_kobuki.cpp.o] Error 1 CMakeFiles/Makefile2:396: recipe for target 'src/CMakeFiles/ftdi_kobuki.dir/all' failed

edit flag offensive delete link more

Comments

That was the instructions I tried. I cannot get liblz4-dev installed so I am stuck there.

The link was in my email notification: http://wiki.ros.org/ROSberryPi/Instal...

TommyP gravatar imageTommyP ( 2015-02-08 03:07:25 -0500 )edit

What line fails for you, and what is the error message

nickw gravatar imagenickw ( 2015-02-08 03:39:06 -0500 )edit

installing libftdi-dev fixed my error

nickw gravatar imagenickw ( 2015-02-08 04:22:47 -0500 )edit

I seemed to have gotten the wrong libz4 deb. Getting the right one solved the deb install problem. Now it compiles better... I wonder how I got the wrong version of the file.

TommyP gravatar imageTommyP ( 2015-02-08 05:48:08 -0500 )edit

And the compilation for ros-comm succeeded.

TommyP gravatar imageTommyP ( 2015-02-08 06:00:43 -0500 )edit

I moved onto the linaro image here http://www.raspberrypi.org/forums/vie... and got base comm and turtlebot + turtlebot_navigation to build. Have been able to keyop turtlebot and fired up gmapping. depth camera appears to work, not RGB camera at the moment.

nickw gravatar imagenickw ( 2015-02-14 11:57:22 -0500 )edit

@TommyP, I'm getting the same error RE: libl4z-dev. Can you share a bit more about which version you had and which version you switched to? Did you do anything differently, or just try again?

devtron gravatar imagedevtron ( 2015-02-19 04:20:22 -0500 )edit

I think I just tried again with installing it and suddenly it worked. I might have tried to install lib4z-dev from package also.

TommyP gravatar imageTommyP ( 2015-02-19 09:38:37 -0500 )edit
0

answered 2015-03-22 03:41:52 -0500

tfoote gravatar image

If you can start with an Ubuntu Trusty image you should be able to follow the standard Ubuntu Armhf instructions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-02-07 18:20:13 -0500

Seen: 808 times

Last updated: Mar 22 '15