ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Installing ROS-Groovy Mobile on Raspbian

asked 2013-02-19 15:27:06 -0600

updated 2014-01-28 17:15:19 -0600

ngrennan gravatar image


I have been trying to install ROS Groovy Mobile on my RPi. I keep getting an error when I run sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y which returns ERROR: the following rosdeps failed to install apt: command [sudo apt-get install -y python-rospkg] failed

Any ideas how to get around this? I cannot install the package at all. I commented out the dependency in roslib.

Anyone have an image of ROS Groovy Mobile or Full installed on Raspbian?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-02-19 19:31:31 -0600

kalectro gravatar image

good news, there is exactly what you ask for

push this link hard!

Have fun with it :)

edit flag offensive delete link more


That was the guide I was using. I cannot get past 5.6 due to the error above. Were you able to install it?

tonybaltovski gravatar image tonybaltovski  ( 2013-02-20 05:32:03 -0600 )edit

Yes and I also posted an image file on the very top of the tutorial ;) There is a red box right under the command which tells you that this command will fail and how to fix it

kalectro gravatar image kalectro  ( 2013-02-20 06:31:57 -0600 )edit

Sorry I did not notice the link. Thank you so much for that. I edited many package.xml that contained python-rospkg but it still fails. I will try the image now. Thank you again. I'd still like to be able to install from source but I'll try that in my spare time.

tonybaltovski gravatar image tonybaltovski  ( 2013-02-20 06:35:51 -0600 )edit

I added the robust option for rosdep (-r) which should give you a summary of all packages which have not been installed successfully at the end. If there is no ERROR and only some apt-get commands which were not found, you will be fine and can go on with the tutorial. Feel free to edit it as well

kalectro gravatar image kalectro  ( 2013-02-20 06:55:12 -0600 )edit

Thank you. I just tried the image and it works perfectly. I will try to compile it from source another time. Your help with much appreciated.

tonybaltovski gravatar image tonybaltovski  ( 2013-02-21 16:15:56 -0600 )edit

@kalectro Do you use the RPi as the master or another laptop? I configured my laptop as the masters for my RPi. I can see the rostopic list but I cannot echo any topics. When I try to use a simple command to publish such as rostopic pub /test std_msgs/Int32 300, I can see it locally on the PRi.

tonybaltovski gravatar image tonybaltovski  ( 2013-02-23 09:59:09 -0600 )edit

Any ideas? (Sorry I ran out of characters)

tonybaltovski gravatar image tonybaltovski  ( 2013-02-23 09:59:33 -0600 )edit

It will also work with a master running somewhere else. The issue you have might be due to your DNS. Try setting ROS_IP, that should work

kalectro gravatar image kalectro  ( 2013-02-23 13:55:05 -0600 )edit

answered 2013-02-20 11:12:48 -0600

i'm currently installing ROS groovy onto Rpi, and had the same issue. It was related to my outdated printout of the instructions. Double check the install instructions. they've been update a few times in the last few days.

python-rospkg is related to installing python-pip and/or python-gtk2 back in step 2 "Install the core dependencies". To fix python-rospkg (plus others) I ...
sudo apt-get install python-pip python-gtk2
sudo apt-get update
sudo apt-get upgrade (to be sure, to be sure, to be sure)
this removed 8 of the 12 depenicies listed in rosdep check. the remaining 4, I removed manually from the package.xml files.
And all was good in the land of catkin...

On a side note: catkin_make_isolated takes 24-36 hours to run, most of the time is cmake'ing PCL.
Also a 8GB sd card isn't big enough. 16gb is working for far.
Hope this helps.

edit flag offensive delete link more


I also added a section explaining how to set up a chroot environment to reduce the time. Maybe my SD card was slow but PCL alone took 24 hours natively

kalectro gravatar image kalectro  ( 2013-02-20 16:01:02 -0600 )edit

yep, saw that, but as i'm still getting my head around ROS / Raspbian / Rpi, didn't want to complicate things by installing ROS on Raspbian, emulated in qemu, in ubuntu, in a virtual box on windows7. next time definately, i'm only patient the first time.

Razorback gravatar image Razorback  ( 2013-02-20 16:35:00 -0600 )edit

Question Tools

1 follower


Asked: 2013-02-19 15:27:06 -0600

Seen: 385 times

Last updated: Feb 20 '13