ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Unable to install ROS Groovy on Raspberry Pi

asked 2014-02-18 10:16:06 -0500

WMHanif gravatar image

updated 2016-10-24 08:59:24 -0500

ngrennan gravatar image

Hello all,

I'm currently trying to install ROS on my Raspberry Pi, I just followed the instruction on and got some errors, error 404 server not found, when I do some researching, I found out that the instruction is outdated.

for information, I've install Raspbian from NOOBs for my Raspberry Pi an running on Raspberry Pi Type B

anyone could help ?

edit retag flag offensive close merge delete


A quick glance suggests that the repository still exists, and should probably still work. Can you add the exact command and error you're seeing to your question?

ahendrix gravatar image ahendrix  ( 2014-02-18 10:19:19 -0500 )edit

when I reload apt sources, I got this error: Err wheezy/main armhf Packages 404 Not Found W: Failed to fetch 404 Not Found any ideas ?

WMHanif gravatar image WMHanif  ( 2014-02-18 16:02:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-02-18 16:49:36 -0500

ahendrix gravatar image

It looks like the repository at is no more. Try removing that line from your sources and using the builds for raspbian that are located in instead.

edit flag offensive delete link more


how to remove that line because the line reloads itself when I execute the "sudo apt-get update" command

WMHanif gravatar image WMHanif  ( 2014-02-19 12:55:04 -0500 )edit

I tried to replace it with it but still not working

mistrysiddh gravatar image mistrysiddh  ( 2021-12-07 10:07:40 -0500 )edit

Question Tools

1 follower


Asked: 2014-02-18 10:16:06 -0500

Seen: 392 times

Last updated: Feb 18 '14