Ask Your Question
0

set unknown_cost_value in costmap

asked 2014-11-25 10:18:33 -0600

Stefano Primatesta gravatar image

updated 2014-11-25 10:19:50 -0600

How can I set "unknown_cost_value" in costmap?

In /map there are unknown value set to -1, but when /map is converted into costmap, unknow value is set to 0, like free space.

I tried to set parameters in costmap_common_params.yaml but it doesn't works

   global_costmap:
   global_frame: /map
   robot_base_frame: /base_footprint
   update_frequency: 4.0
   publish_frequency: 4.0
   static_map: true
   static_layer: {enabled: true, lethal_cost_threshold: 100, track_unknown_space: true, unknown_cost_value: -1}   
   transform_tolerance: 0.5

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-25 11:01:12 -0600

Stefano Primatesta gravatar image

Thanks @David Lu , but I've already add:

   obstacle_layer: {enabled: true, lethal_cost_threshold: 100, track_unknown_space: true, unknown_cost_value: -1}

in costmap_common_params.yaml.

It works!

edit flag offensive delete link more
1

answered 2014-11-25 10:41:17 -0600

David Lu gravatar image

Try setting track_unknown_space to true in the costmap namespace.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-25 10:18:33 -0600

Seen: 589 times

Last updated: Nov 25 '14